How can I ungroup 'Find' occurances in EAP

EAP 138-1505 changed the Find behavior so that results are now grouped into 'Unclassified occurances', 'Usage in comments' and 'Usage in string constants', instead of being simply grouped by directory/file. I think the old interface was easier to work with, and the new one is disjointed. I've toggled all of the 'Group by...' buttons, but can't get them to all be in a single group again.

Does anyone know if there's a way to get the old behavior back?

5 comments
Comment actions Permalink

Hi there,

If I correctly understand your issue ... such ability will be available in next PhpStorm v8 EAP build -- http://youtrack.jetbrains.com/issue/IDEA-128559

0
Comment actions Permalink

No Andrey,

The issues bothers (and annoys) me as well from I started using WS 9 EAP
Old good Find in Files result was re-branded. Along with 'Unclassified search' WS added 'Search in strings constants'

I pretty sure this is _BAD_ idea, which is not ever have chance to live.

Please remove it from WS/IDEA as soon as possible!


Thanks,

Oleg

PS. I'm really thinking rollback to WS 8 because of this paranoia idea.

0
Comment actions Permalink

The issues bothers (and annoys) me as well from I started using WS 9 EAP
Old good Find in Files result was re-branded. Along with 'Unclassified search' WS added 'Search in strings constants'

Could you please clarify what you mean here (preferably with screenshots) -- I have failed to understand what the exact problem you are having here.

because of this paranoia idea

Hmm..?

-----

If you are referring to the grouping issue then you should clearly see from the aforementioned ticket that it was fixed. When it will be available in WebStorm v9 EAP build I do not know -- but it definitely will be in next EAP.

0
Comment actions Permalink

Yes, I have noticed, it is fixed in IDEA last EAP version...
Please add it to the WS

Thanks, Oleg

0
Comment actions Permalink

You're right, thanks for the link to #128559.

(I accidentally marked your answer as 'helpful', but it should have been marked as 'correct'. I don't see any option to change it now, though. Sorry about that.)

0

Please sign in to leave a comment.