[Server Integration] Can't connect to target VM

Hi.

I am working on WebPrime(Our AppServer) Integration Plugin with IntelliJ v4.5.3.
After thousands of trial & error, the plugin now has basic features.. (startup, stop, dd, deploy)

===================================================
1. Failed to establish connection to the target VM
===================================================

But when I tried to startup server in debug mode, got following error.

"Check your run/debug configuration. Failed to establish connection to the target VM at '127.0.0.1:19999' using socket transport"

I searched this forum.. and found some similar questions (w/o no answer).
Regardless of above error, I can connect to server outside IntelliJ (using Eclipse Plugin). And debug works fine.


==============================
2. Can't modify debug options
==============================

We have used debug option like
"-Xdebug -Xnoagent -Xrunjdwp:transport=dt_socket,address=19999,suspend=n,server=y"

But IntelliJ Server Debug Option seems to be somewhat different... and to be fixed.
(I don't kwow much about java debugging.. but above option has worked..)

So I unchecked "Pass Environment Variables" and insert my debug option in boot script.


=========================
Environment :
IntelliJ 4.5.3 build 2250
OS Windows 2000

=========================
kbahn@tmax.co.kr
http://www.tmaxsoft.com









2 comments

Sorry, it was my setting problem.

Debug seems to be working....

0

What was the solution? Can you please post it?

0

Please sign in to leave a comment.