JsTestDriver behaves differently running server inside or outside of IDE

Using Windows 7 x64  & Webstorm 8 trial + the TFS plugin and using JsTestDriver forunit tests.

We have 4 test cases with 240+ tests and growing -the project is just getting started.  If I run the tests with the integrated server and capture Chrome, I will get errors like:

NetworkError: Failed to execute 'send' on 'XMLHttpRequest': Failed to load 'http://localhost:9876/test/Languages/English/UIStrings.xml'.
Error: Failed to execute 'send' on 'XMLHttpRequest': Failed to load 'http://localhost:9876/test/Languages/English/UIStrings.xml'.


If I run an external server and Chrome externaly, set up the test case to use an external server, everything works, except I can't debug the tests in WS.

If I take WS outof the picture and run the server, Chrome and the test cases from a command line, it all works.

I am limited as to how much code I can share due to Company Policy.

I really love Resharper (use it for C#) and would really like to love WS as much - but this debugging issue is a real show stopper.
Anybody have any ideas?
1 comment
Comment actions Permalink

So I love it when I answer my own question. I had to set the FORCE CORS in the Chrome extension...

0

Please sign in to leave a comment.