Stop phpStorm from using port 63342

Since phpStorms built in server setup I can not use the browser icons
to load a file because it always opens using http://localhost:63342/ instead of my local
host http://localhost/

I have been through all of the configurations for server / PHP / deploy, etc ... in phpStorms settings with no luck.
How do I stop it from doing that?

7 comments

Hi there,

Please make sure that the Deployment entry is marked as Default for this project. This should be enough (always works for me).

0

Thats a bit iritating but worked, thanks. Didn't have to do that before the phpStorm built in server.

0

As of v7 built-in web server is default option when opening files in browser (if no default server is configured). In previous versions (when no built-in server was available) such action was opening file using full path on file system (i.e. file:///C:/Projects/...)

And as far as I'm aware .. you had to mark one of the deployment entries as Default to use http://localhost/ addresses even in previous versions (otherwise file:/// protocol was used -- at very least it was always the case for me).

0

I have been running phpStorm for since version 1 so I am sure it was marked before or setup to use localhost.

But on version 7 I can't mark default in the Global settings. Its not an option.
Only when the project is open, then I can mark it as default.

It looks like just projects created in the latest versions. Old projects are still repecting my normal localhost.

At least I know how to fix it now. Thank you.

0

Hello.
I use PhpStorm EAP 138.1505 .
Although I force "use this server as default" , while using XAMPP and pointing to http://localhost (where my projects' files live) - all HTML files are opened by default via http://localhost:63342 and PHP files are opened by default via http://localhost.
I would agree to use http://localhost:63342 for all my files, BUT http://localhost:63342 is by far slower ...
How can I force my HTML files be opened via http://localhost when I press Alt + F2 ?

0
  • Greetings Andriy, how do you mark the server as default?
0

@TEO Jiacheng

Settings/Preferences | Build, Execution, Deployment | Deployment

Entry marked as default will be in bold

0

Please sign in to leave a comment.