Unknown pseudo selector - how to ignore?

In my css file I have pseudo code for input placeholder:

input::-webkit-input-placeholder {
    color: rgba(0,5,143,.5);
    text-transform: uppercase;
}

it is showing as an error in red (e.g. -webkit-input-placeholder). The problem, this is valid pseudo code.

Is there someplace I can add valid pseudo code so i can get an indication my CSS file is error free. I have having to ignore the indicator showing there is a problem, so I'm finding myself ignoring actual errors.

Regards,
Rich

7 comments
Comment actions Permalink

Yeah .. I see it in red .. but I do not see the actual error message...

Anyway. Either

  • Disable that inspection completely -- "Settings | Inspections | CSS | Invalid elements | Invalid CSS pseudo selector"
  • or suppress it just for that line/ruleset. For that:
    • Alt+Enter while having caret placed on the error (on that selector)
    • In appeared popup menu choose correct menu entry (most likely there will be only one entry) and expand submenu (arrow right ... or click on small triangle)
    • Choose appropriate "Suppress" option from sub menu
    • At the end it should look like this:
/*noinspection CssInvalidPseudoSelector*/
input::-webkit-input-placeholder {
    color: rgba(0,5,143,.5);
    text-transform: uppercase;
}

I am using version 7.1.3 and have verified I have the latest update.

Yes, you have latest stable release.

v8 is still in EAP stage .. so cannot be upgraded this way -- it has to be installed manually (NOTE: v8 can be run alongside with v7 as IDE settings are stored in separate folder; just backup project settings (.idea subfolder) if you want to go back using v7).

As I've already said earlier: IDE shows no errors in v8 -- must have been fixed (one way or another). Although corresponding ticket WEB-8438 still has "Open" status.

1
Comment actions Permalink

Andriy,

To me, when it shows in red indicates critical, however, the css will work correctly, I'm assuming this is letting me know there's an issue the needs immediate attention as oppose to an invalid value for an attribute.

I did discover the pseudo css settings and that is giving me what I need.

Just another learning experience.

Thanks!
Rich

1
Comment actions Permalink

Hi there,

1) IDE and version used?

2) Screenshot with the error message, please.

I've checked in PhpStorm v8 EAP build and it shows no errors here (.css file)
screen01.png

0
Comment actions Permalink

Andriy,

I am using phpStorm version 7.1.3. I've checked for updates and I'm told I am up to date.

0
Comment actions Permalink

Andriy

I am using version 7.1.3 and have verified I have the latest update.

You will see the pseudo code is showing 'red':

0
Comment actions Permalink

Andriy

I am using version 7.1.3 and have verified I have the latest update.

You will see the pseudo code is showing 'red':

0
Comment actions Permalink

Here's the image



Attachment(s):
JetBrain CSS code.jpg
0

Please sign in to leave a comment.