Can't run JBoss configuration

I'm trying to run J2ee app from Idea on the remote JBoss server. Until now I've just used ant script to build/deploy app. But now I want to check the Idea's way of doing this. In Run/Debug configuration I'm setting up the host, leaving default values for ports. Deployment method I select is shared filesystem (I have the remote server's folder mapped locally).

But now, when I try to run the configuration, Idea immediately gives me an error pop up: "Error running Myhost JBoss: Unable to connect to the myhost:8080".

The Jboss is there and running fine. Any ideas on what is wrong here? This pop up is thrown before any attempts to compile/deploy - just after I click "run" button. And there is nothing in the log file either.

Idea 5.0.1, Jboss Integration plugin 2.0-eap12

2 comments
Comment actions Permalink

victorstar wrote:

I'm trying to run J2ee app from Idea on the remote JBoss server. Until now I've just used ant script to build/deploy app. But now I want to check the Idea's way of doing this. In Run/Debug configuration I'm setting up the host, leaving default values for ports. Deployment method I select is shared filesystem (I have the remote server's folder mapped locally).

But now, when I try to run the configuration, Idea immediately gives me an error pop up: "Error running Myhost JBoss: Unable to connect to the myhost:8080".

The Jboss is there and running fine. Any ideas on what is wrong here? This pop up is thrown before any attempts to compile/deploy - just after I click "run" button. And there is nothing in the log file either.

Idea 5.0.1, Jboss Integration plugin 2.0-eap12


You should re-post this on the Plugins forum.

0
Comment actions Permalink

Well, I spoke to the author of the Jboss integration plugin and he said it's Idea that tries to establish some sort of connection prior giving control to the plugin. So I thought someone may share some ideas here.

But anyway that might be a good idea to copy this post in the Plugins forum as well, thanks.

0

Please sign in to leave a comment.