Database Source No Longer Saves Credentials

A few versions ago, the storage mechanism for the Database sources was change (at least the structure of the XML changed.) Now, even thought it appears to save my credentials, I get prompted to enter them again every time I close and re-open PHPStorm.

17 comments

Actually, it's losing the credentials even without closing PHPStorm. Just asked me for the credentials in the middle of working on something.

0

What DB source do you sue? Can you restart IDE, reproduce the issue and attach the log file?
I don't really believe, but maybe File | invalidate caches would work?

0

MySQL, but it's so inconsistent. Worked fine all day yesterday. This morning, I opened PHPStorm and the credentials were gone. This is what the dataSources.local.xml file looked like:

<?xml version="1.0" encoding="UTF-8"?>
<project version="4">
  <component name="dataSourceStorageLocal">
    <data-source name="PRIDE" uuid="7036f377-4a66-4680-a2cc-3283bd8d7b22">
    </data-source>
  </component>
</project>

And so I added the credentials and this is what it looked like:

<?xml version="1.0" encoding="UTF-8"?>
<project version="4">
  <component name="dataSourceStorageLocal">
    <data-source name="PRIDE" uuid="7036f377-4a66-4680-a2cc-3283bd8d7b22">
      <secret-storage>master_key</secret-storage>
      <user-name>xxxxx</user-name>
    </data-source>
  </component>
</project>



Attachment(s):
idea (partial).log.zip
0

Hi,

Sorry for the delay, I was out of office. Is issue still reproducible with the latest EAP?

0

I just checked and yes, my credentials are gone again:

Capture.PNG

0

I synchronize my project with SugarSync. Maybe something is happening there. I'm testing that now. I added my credentials, closed PHPStorm, let SugarSync complete, opened PHPStorm on my other computer and credentials are still there. Now, I might not have actually re-entered my credentials in this latest EAP, so we can give it a few days and check again.

0

The "Remember password" checkbox controls where password is actually stored.

  • Checked: IDE-scoped password database protected by master password
  • Unchecked: memory only, cleaned on some timeout
  • Crossed-out: for legacy data-sources password is slightly encoded dataSources.local.xml which is in VCS ignore list by default

So see the screenshot - the password is moved to dataSources.local.xml which is not shared.
See http://youtrack.jetbrains.com/issue/IDEA-125019 for some discussion on the matter.
0

Normally, I check the box (I actually forgot today.)

0

So, I haven't really been using it (paying attention) in a few days, and suddenly, I notice the credentials are gone again. Also, even the cached schema information disappears when this happens (is that normal? If so why?)

0

This is not normal. Please see if .idea/dataSource.local.xml and .idea/dataSource.ids files are present.

If they are not please see if they correctly appears after you set up credentials / loaded schema on IDE "Save All".

And don't forget to include your product version / build number.
This is really-really helpful, because some stuff may break between certain EAPs.
Please see http://youtrack.jetbrains.com/issue/IDEA-123489 .

0

Yes, both of those files are present after this occurs (I checked.)

PS-138.256 currently, but this has been going on since the structure of this changed and PHPStorm began using the file: .idea/dataSource.local.xml (whatever version that was.)

0

http://youtrack.jetbrains.com/issue/IDEA-123489 is either not a valid issue # or somehow I'm blocked from that page:

You have no permissions to view this page

Try to relogin, go to issues page (logged in as 'laurin1'), or contact your system administrator.
Back

0

I've opened the ticket for public. But seems to be you already have the build with the fix.
Please confirm that credentials keep disappearing.

0

This occurred as recently as 2 days ago on the current EAP.

0

Still happening. Just today, lost credentials on 2 different machines. Also, http://youtrack.jetbrains.com/issue/IDEA-123489 is not resolved. This happens as well - not every time, but from time to time
.

0

Thank you. Youtrack is a better place to discuss this problem.

0

Please sign in to leave a comment.