idea 5 gui preview broken

I don't know why my forms are empty. I put a few controls after creating
a fresh java project on a form. I then press preview and the form is empty.
I was able to do a successful gui form in 4.5 but I have not got one in 5.0.

Is anyone getting their forms to work? Thanks for any help.


5 comments
Comment actions Permalink

Hello Rodrigo,

RG> I don't know why my forms are empty. I put a few controls after
RG> creating a fresh java project on a form. I then press preview and
RG> the form is empty. I was able to do a successful gui form in 4.5 but
RG> I have not got one in 5.0.
RG>
RG> Is anyone getting their forms to work? Thanks for any help.

I tried to reproduce the problem, and the form preview is working correctly
for me. Does it work for you if you create a trivial form with a single label
control?

If the preview fails only on a particular form, could you please file a JIRA
issue and attach the form to it?

--
Dmitry Jemerov
Software Developer
JetBrains, Inc.
http://www.jetbrains.com
"Develop with pleasure!"


0
Comment actions Permalink

Thanks for the reply. I'm thinking its a plugin. A trivial example does not
work for me. When I look at the log file it says something about profiling
error. I will create an issue later. Thanks for now.

Hello Rodrigo,

RG>> I don't know why my forms are empty. I put a few controls after
RG>> creating a fresh java project on a form. I then press preview and
RG>> the form is empty. I was able to do a successful gui form in 4.5
RG>> but I have not got one in 5.0.
RG>>
RG>> Is anyone getting their forms to work? Thanks for any help.
RG>>

I tried to reproduce the problem, and the form preview is working
correctly for me. Does it work for you if you create a trivial form
with a single label control?

If the preview fails only on a particular form, could you please file
a JIRA issue and attach the form to it?



0
Comment actions Permalink

I've reinstall idea. I'm still getting the profiling error:

2005-08-08 19:18:09,140 INFO - om.intellij.util.ProfilingUtil -
java.lang.Exception: To profile application, you should run it with the profiler
agent
at com.yourkit.api.Controller.a(a:24)
at com.yourkit.api.Controller.(a:78) at com.intellij.util.ProfilingUtil.initController(ProfilingUtil.java:35) at com.intellij.util.ProfilingUtil.(ProfilingUtil.java:31) at com.intellij.util.CaptureMemorySnapshotAction.update(CaptureMemorySnapshotAction.java:3) at com.intellij.openapi.actionSystem.impl.Utils.expandActionGroup(Utils.java:30) at com.intellij.openapi.actionSystem.impl.ActionToolbarImpl.updateActions(ActionToolbarImpl.java:63) at com.intellij.openapi.actionSystem.impl.ActionToolbarImpl.(ActionToolbarImpl.java:82) at com.intellij.openapi.actionSystem.impl.ActionManagerImpl.createActionToolbar(ActionManagerImpl.java:114) at com.intellij.openapi.wm.impl.IdeRootPane.a(IdeRootPane.java:21) at com.intellij.openapi.wm.impl.IdeRootPane.updateToolbar(IdeRootPane.java:23) at com.intellij.openapi.wm.impl.IdeRootPane.(IdeRootPane.java:6) at com.intellij.openapi.wm.impl.IdeFrame.]]>(IdeFrame.java:28)
at com.intellij.openapi.wm.impl.WindowManagerImpl.showFrame(WindowManagerImpl.java:69)
at com.intellij.idea.IdeaApplication$IdeStarter.main(IdeaApplication.java:9)
at com.intellij.idea.IdeaApplication.run(IdeaApplication.java:40)
at com.intellij.idea.Main$3.run(Main.java:1)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:461)
at com.intellij.ide.IdeEventQueue.defaultDispatchEvent(IdeEventQueue.java:65)
at com.intellij.ide.IdeEventQueue.a(IdeEventQueue.java:56)
at com.intellij.ide.IdeEventQueue.dispatchEvent(IdeEventQueue.java:160)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:242)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:163)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:157)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:149)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)
2005-08-08 19:18:10,921 INFO - lication.impl.LaterInvocatorEx
- enterModal:com.intellij.openapi.progress.util.SmoothProgressAdapter@113cf51


Anyone know what this is? Is this related to my gui problems?

Thanks for the reply. I'm thinking its a plugin. A trivial example
does not work for me. When I look at the log file it says something
about profiling error. I will create an issue later. Thanks for now.

>> Hello Rodrigo,
>>
RG>>> I don't know why my forms are empty. I put a few controls after
RG>>> creating a fresh java project on a form. I then press preview and
RG>>> the form is empty. I was able to do a successful gui form in 4.5
RG>>> but I have not got one in 5.0.
RG>>>
RG>>> Is anyone getting their forms to work? Thanks for any help.
RG>>>
>> I tried to reproduce the problem, and the form preview is working
>> correctly for me. Does it work for you if you create a trivial form
>> with a single label control?
>>
>> If the preview fails only on a particular form, could you please file
>> a JIRA issue and attach the form to it?
>>


0
Comment actions Permalink

I've figure the problem. My graphics cards is the problem. Thanks.

I've reinstall idea. I'm still getting the profiling error:

2005-08-08 19:18:09,140 INFO -
om.intellij.util.ProfilingUtil -
java.lang.Exception: To profile application, you should run it with
the profiler
agent
at com.yourkit.api.Controller.a(a:24)
at com.yourkit.api.Controller.<init>(a:78)
at
com.intellij.util.ProfilingUtil.initController(ProfilingUtil.java:35)
at com.intellij.util.ProfilingUtil.<clinit>(ProfilingUtil.java:31)
at
com.intellij.util.CaptureMemorySnapshotAction.update(CaptureMemorySnap
shotAction.java:3)
at
com.intellij.openapi.actionSystem.impl.Utils.expandActionGroup(Utils.j
ava:30)
at
com.intellij.openapi.actionSystem.impl.ActionToolbarImpl.updateActions
(ActionToolbarImpl.java:63)
at
com.intellij.openapi.actionSystem.impl.ActionToolbarImpl.<init>(Action
ToolbarImpl.java:82)
at
com.intellij.openapi.actionSystem.impl.ActionManagerImpl.createActionT
oolbar(ActionManagerImpl.java:114)
at com.intellij.openapi.wm.impl.IdeRootPane.a(IdeRootPane.java:21)
at
com.intellij.openapi.wm.impl.IdeRootPane.updateToolbar(IdeRootPane.jav
a:23)
at
com.intellij.openapi.wm.impl.IdeRootPane.<init>(IdeRootPane.java:6)
at com.intellij.openapi.wm.impl.IdeFrame.<init>(IdeFrame.java:28)
at
com.intellij.openapi.wm.impl.WindowManagerImpl.showFrame(WindowManager
Impl.java:69)
at
com.intellij.idea.IdeaApplication$IdeStarter.main(IdeaApplication.java
:9)
at com.intellij.idea.IdeaApplication.run(IdeaApplication.java:40)
at com.intellij.idea.Main$3.run(Main.java:1)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:461)
at
com.intellij.ide.IdeEventQueue.defaultDispatchEvent(IdeEventQueue.java
:65)
at com.intellij.ide.IdeEventQueue.a(IdeEventQueue.java:56)
at
com.intellij.ide.IdeEventQueue.dispatchEvent(IdeEventQueue.java:160)
at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThr
ead.java:242)
at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThrea
d.java:163)
at
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:157)
at
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:149)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)
2005-08-08 19:18:10,921 INFO -
lication.impl.LaterInvocatorEx
-
enterModal:com.intellij.openapi.progress.util.SmoothProgressAdapter@11
3cf51

Anyone know what this is? Is this related to my gui problems?

>> Thanks for the reply. I'm thinking its a plugin. A trivial example
>> does not work for me. When I look at the log file it says something
>> about profiling error. I will create an issue later. Thanks for now.
>>
>>> Hello Rodrigo,
>>>
RG>>>> I don't know why my forms are empty. I put a few controls after
RG>>>> creating a fresh java project on a form. I then press preview and
RG>>>> the form is empty. I was able to do a successful gui form in 4.5
RG>>>> but I have not got one in 5.0.
RG>>>>
RG>>>> Is anyone getting their forms to work? Thanks for any help.
RG>>>>
>>> I tried to reproduce the problem, and the form preview is working
>>> correctly for me. Does it work for you if you create a trivial form
>>> with a single label control?
>>>
>>> If the preview fails only on a particular form, could you please
>>> file a JIRA issue and attach the form to it?
>>>


0
Comment actions Permalink

Hello Rodrigo,

RG> I've reinstall idea. I'm still getting the profiling error:
RG>
RG> 2005-08-08 19:18:09,140 INFO -
RG> om.intellij.util.ProfilingUtil -
RG> java.lang.Exception: To profile application, you should run it with
RG> the profiler
RG> agent

The profiling error is harmless and is not related to the GUI preview. It
will no longer be displayed in IDEA 5.0.1.

--
Dmitry Jemerov
Software Developer
JetBrains, Inc.
http://www.jetbrains.com
"Develop with pleasure!"


0

Please sign in to leave a comment.