Idea 5 and Java5

HI all,

I just tried idea 5 on linux. As it doesn't ship its own jvm anymore I tried to start it with Java5. Everything cool except that the debugging doesn't work:

java.ClassNotFoundException: com.sun.tools.jdi.SharedMemoryTransportService

I think this problem has been with IntelliJ for a while but I thought that idea5 would support Java5 as its running JVM? Does it not.

What is the recommended JVM for IDEA 5

7 comments
Comment actions Permalink

Please make sure that your classpath also contains a tools.jar from the JDK distribution. This jar is required for IDEA debugger.

--
Best regards,
Eugene Zhuravlev
Software Developer
JetBrains Inc.
http://www.jetbrains.com
"Develop with pleasure!"

"Michael Grey" <no_mail@jetbrains.com> wrote in message news:21753963.1123488347156.JavaMail.itn@is.intellij.net...

HI all,

>

I just tried idea 5 on linux. As it doesn't ship its own jvm anymore I tried to start it with Java5. Everything cool except that
the debugging doesn't work:

>

java.ClassNotFoundException: com.sun.tools.jdi.SharedMemoryTransportService

>

I think this problem has been with IntelliJ for a while but I thought that idea5 would support Java5 as its running JVM? Does it
not.

>

What is the recommended JVM for IDEA 5



0
Comment actions Permalink

Or you may have old tools.jar (from other JDK version) in IDEA classpath - this also will lead to such error.

--
Best regards,
Eugene Zhuravlev
Software Developer
JetBrains Inc.
http://www.jetbrains.com
"Develop with pleasure!"

"Eugene Zhuravlev (JetBrains)" <jeka@intellij.com> wrote in message news:dd7cvg$6s5$1@is.intellij.net...

Please make sure that your classpath also contains a tools.jar from the JDK distribution. This jar is required for IDEA debugger.

>

--
Best regards,
Eugene Zhuravlev
Software Developer
JetBrains Inc.
http://www.jetbrains.com
"Develop with pleasure!"

>

"Michael Grey" <no_mail@jetbrains.com> wrote in message news:21753963.1123488347156.JavaMail.itn@is.intellij.net...

>> HI all,
>>
>> I just tried idea 5 on linux. As it doesn't ship its own jvm anymore I tried to start it with Java5. Everything cool except that
>> the debugging doesn't work:
>>
>> java.ClassNotFoundException: com.sun.tools.jdi.SharedMemoryTransportService
>>
>> I think this problem has been with IntelliJ for a while but I thought that idea5 would support Java5 as its running JVM? Does it
>> not.
>>
>> What is the recommended JVM for IDEA 5
>



0
Comment actions Permalink

I have the correct tools.jar in the classpath (idea.sh is setting it)
but it does not contain com.sun.tools.jdi.SharedMemoryTransportService.
I guess sun removed it in Java5

mike

0
Comment actions Permalink

but it does not contain com.sun.tools.jdi.SharedMemoryTransportService.
I guess sun removed it in Java5


AFAIK it was always available only for windows. Anyway, I'd recommend always using socket transport.

--
Best regards,
Eugene Zhuravlev
Software Developer
JetBrains Inc.
http://www.jetbrains.com
"Develop with pleasure!"


0
Comment actions Permalink

Ok, How do I specify that? I'am not remote debugging. I just want to
start a debug session of a junit testcase.

On Mon, 2005-08-08 at 16:47 +0400, Eugene Zhuravlev (JetBrains) wrote:

but it does not contain com.sun.tools.jdi.SharedMemoryTransportService.
I guess sun removed it in Java5


AFAIK it was always available only for windows. Anyway, I'd recommend always using socket transport.


0
Comment actions Permalink

BTW I just checked Debugger Transport is set to Socket anyway. shared
memory is disabled.

I think I copied my config from windows. Can you tell me which config
file I need to tweak to get rid of it

mike

On Mon, 2005-08-08 at 15:05 +0200, GreyWind wrote:

Ok, How do I specify that? I'am not remote debugging. I just want to
start a debug session of a junit testcase.

On Mon, 2005-08-08 at 16:47 +0400, Eugene Zhuravlev (JetBrains) wrote:

but it does not contain com.sun.tools.jdi.SharedMemoryTransportService.
I guess sun removed it in Java5


AFAIK it was always available only for windows. Anyway, I'd recommend always using socket transport.


0
Comment actions Permalink

ok,

That was it I just had to open the debugger settings and save it once. I
guess the windows config still had the shared memory inside

thanks for the hints

mike

On Mon, 2005-08-08 at 15:05 +0200, GreyWind wrote:

Ok, How do I specify that? I'am not remote debugging. I just want to
start a debug session of a junit testcase.

On Mon, 2005-08-08 at 16:47 +0400, Eugene Zhuravlev (JetBrains) wrote:

but it does not contain com.sun.tools.jdi.SharedMemoryTransportService.
I guess sun removed it in Java5


AFAIK it was always available only for windows. Anyway, I'd recommend always using socket transport.


0

Please sign in to leave a comment.