Mac OS X (Tiger) Keymap Trouble

Hi,

I'm totally lost here. I've been using IDEA since v3 on Windows and recently switched to Mac when Tiger came out. To the point:

The default Mac OS X Keymap maps "Run" to "shiftf9" and "Debug" to "shiftf10". I've tried everything but can't figure out how to actually use those 2 shortcuts since all they do is map to the "slow" expose functions (All Windows, Application Windows). Even if I remap those keys to something else the "slow" part still remains on the shift+f9/f10 and overrides IDEA.

Is my mac messing with me or did I just screw something up? I can't be the only one with this issue? I know its not a IDEA Issue yet the default keymap must always have this issue so its kinda related.

Any hints?

thanks,
/thomas

12 comments
Comment actions Permalink

Thomas


On my PowerBook, I unmapped all the Exposé shortcuts, but for "All
Windows" that I mapped to the 'Fn' key. It works fine that way. No
"slow" stuff problem.
I suggest you install the DescribeKey plugin (mapped to Alt-Command-K).
It tells you what actions are mapped to a given shortcut.


Alain

0
Comment actions Permalink

Thanks for the reply. I tried the plugin but guess what happens when I try shift+f9/f10: Yep, expose does its thing and the plugin never receives the keystroke.

I tried remapping the key in every possible way I can think of but the shift "slow" problem remains since I cannot find an option to change that.

0
Comment actions Permalink

Another Problem I forgot to mention.

"Make Project" is mapped to CommandF9 by default. Now that works fine UNTIL I press just F9. Every following CommandF9 just results in nothing.

This can't be correct right?

0
Comment actions Permalink

Thomas

>..when I try shift+f9/f10: Yep, expose does its thing
>

It means you didn't succeed in unmapping. See the attached screenshot:







Alain




Attachment(s):
=?UTF-8?B?dW5tYXBwZWRFeHBvc2XMgS5wbmc=?=
0
Comment actions Permalink

I unmapped everything (tried that before too). Still no success.



Attachment(s):
Picture 1.png
0
Comment actions Permalink

Alain, I appreciate your help and could you please test something for me real quick?

restart IDEA
press Command + F9 (should be Make Project IF you are using the default keymap)
press Shift + F9 (should be "Debug")
hit Escape (cancel the Debug Dialog)
press Command + F9 (SHOULD Make Project, but it never does for me)

If it works for you its definitly something with my Mac.

Thanks!

0
Comment actions Permalink

Thomas

>Alain, I appreciate your help and could you please test something for me real quick?
>

>

IDEA works fine on Tiger.
If Exposé keeps working despite you unmapping all its shortcuts, the
problem is with your Mac, not with IDEA.

Alain

0
Comment actions Permalink

Did you try exactly those steps? Seriously I'm going crazy here. :(

0
Comment actions Permalink

Thomas

>Did you try exactly those steps? Seriously I'm going crazy here. :(

>

Once again, IDEA works fine on MacOS. They've even added menu shortcuts,
à-la Windows. It's something with your settings.
Did it ever work fine before?
Did you customize anything?

You should try and solve the Exposé problem: if you unmap its shortcuts,
they should stop working, shouldn't they?

Alain

0
Comment actions Permalink

Are you using the Mac OS X keymap? (default, unmodded)
Did you try the steps I mentioned (all, in THAT order)?
Did it work?

Please, if you really want to help out; answer all 3 questions with yes OR no. It won't take longer than 1min and will save my hours of reinstalling my system.

I'm trying to solve a problem here and I'm guessing its my system (although I can't explain why since IDEA 4.5 and 5 behave the same) still I need some kind of proof that it IS my system.

Thanks in advance,
/thomas

0
Comment actions Permalink

Thomas

yes + yes + yes

0
Comment actions Permalink

Thanks alot. Guess I need to redo the system for some weird reason :(

0

Please sign in to leave a comment.