Intellij 4.5 on Mac 10.4.1 with JDK 1.5

I have been playing around with JDK 1.5 on my Mac. I installed JDK 1.5 and did a few tests to make sure it was running. I tried to run Intellij and got the nice little error message saying only 1.4 is supported on Mac. So I switched my current java version back to 1.4. I launched Intellij again and got the same error message. For some reason Intellij thinks I am still running JDK 1.5. From my terminal window, when I type java -version it is coming up with JDK 1.4 so I am really confused. I have logged out as well as rebooted, but that has not helped.

Does anyone know how to fix this?

3 comments
Comment actions Permalink

In article <28856659.1119891297120.JavaMail.itn@is.intellij.net>,
Jason <no_mail@jetbrains.com> wrote:

I have been playing around with JDK 1.5 on my Mac. I installed JDK 1.5 and
did a few tests to make sure it was running. I tried to run Intellij and got
the nice little error message saying only 1.4 is supported on Mac. So I
switched my current java version back to 1.4. I launched Intellij again and
got the same error message. For some reason Intellij thinks I am still
running JDK 1.5. From my terminal window, when I type java -version it is
coming up with JDK 1.4 so I am really confused. I have logged out as well as
rebooted, but that has not helped.

Does anyone know how to fix this?


I believe that it is asking for version 1.4+, rather than 1.4*, so the
JVM is getting launched with the highest version of Java available - 1.5.

Assuming this, you need to tell the app to launch with only 1.4 versions
of the JVM.

Do a 'show contents' on the intellij app.
Navigate to the Contents directory
Bring up the Info.plist text file in a text editor.
Look for the
JVMVersion 1.4+ entry and change it to JVMVersion 1.4* Alternatively, set the no jdk check flag in the Properties dict. Look for the Properties line, and in the following section, add the following entry: idea.no.jdk.check true Attached is my info.plist as an example - it is for Iridia, so do not copy it completely, but it should give you an example of both of the above. In my case, I deactivated the version check and ran with 1.5. CFBundleDevelopmentRegion English CFBundleDocumentTypes CFBundleTypeExtensions ipr CFBundleTypeIconFile idea.icns CFBundleTypeName IntelliJ IDEA Project File CFBundleTypeRole Editor CFBundleExecutable idea CFBundleIconFile idea.icns CFBundleInfoDictionaryVersion 6.0 CFBundleName IntelliJ IDEA CFBundlePackageType APPL CFBundleSignature ???? CFBundleGetInfoString Irida, Copyright JetBrains s.r.o., (c) 2000-2005 CFBundleShortVersionString Irida CFBundleVersion 3296 Java ClassPath ]]>$APP_PACKAGE/lib/extensions.jar:$APP_PACKAGE/lib/openapi.jar:$APP
PACKAGE/lib/idea.jar:$APPPACKAGE/lib/jdom.jar:$APP_PACKAGE/lib/log4j.ja
r JVMVersion 1.5+ MainClass com.intellij.idea.Main Properties CVS_PASSFILE ~/.cvspass com.apple.mrj.application.live-resize false idea.config.path ~/Library/Preferences/IntelliJ IDEA idea.popup.weight medium idea.system.path ~/Library/Caches/IntelliJ IDEA/ idea.plugins.path ~/Library/Application Support/IntelliJ IDEA/ java.endorsed.dirs idea.smooth.progress false apple.laf.useScreenMenuBar true idea.no.jdk.check true VMOptions -Xms64m -Xmx192m -Xbootclasspath/p:../lib/boot.jar -ea -Xrunyjpagent:port=10100 WorkingDirectory $APP_PACKAGE/bin ]]>

--
Scott Ellsworth
scott@alodar.nospam.com
Java and database consulting for the life sciences

0
Comment actions Permalink

Changing the the Info.plist file worked! Thank you.

0
Comment actions Permalink

In article <10041318.1120050706596.JavaMail.itn@is.intellij.net>,
Jason <no_mail@jetbrains.com> wrote:

Changing the the Info.plist file worked! Thank you.


Welcome.

Scott

--
Scott Ellsworth
scott@alodar.nospam.com
Java and database consulting for the life sciences

0

Please sign in to leave a comment.