0

Completely turning off HTML/XHTML tag completion

This is the sort of question I feel stupid for asking, because almost certainly it's just due to me missing a checkbox in the options somewhere. But...

Is there any way to tell PhpStorm that I really don't want it to complete my HTML tags for me?

I've unchecked all the seemingly relevant options in the IDE preferences (Editor > Smart Keys > Automatically insert closing tag, Emmet > Enable XML Emmet, etc.), but still, when I type an opening DIV tag and then start to type the closing tag, PhpStorm completes the closing tag as soon as I type the slash. Which is really frustrating since I'm used to just typing it myself, so having PhpStorm "help" me throws off my typing rhythm.

Like I said, I'm sure this is just a case of operator cluelessness, so any enlightenment that can be offered would be gratefully received.

3 comments

Please sign in to leave a comment.