XDebug not stopping at breakpoints in External Libraries

Hello Everyone,

PhpStorm works wonders with Xdebug and it is a pleasure to use; however, if I set a breakpoint in an external library (PHP Include Paths) the breakpoint is not working.
If I debug step by step, I can get into the external library and the debug works just fine, just it does not stop in the breakpoint.

I have checked the paths (uppercase/lowercase) and everything seems to be in order

Any suggestion/hints?

My setup:
phpstorm 7.1.2
MAMP 2.2
PHP Version 5.5.3
with Xdebug v2.2.3

Some additional logs... (the breakpoints in MAINSITE works, those in EXTERNALLIBRARY don't)

2014-06-01 10:35:43,963 [1293010]   INFO - s.impl.stores.FileBasedStorage - Document was not loaded for $APP_CONFIG$/emmet.xml file is null
2014-06-01 10:36:02,624 [1311671]  DEBUG - .connection.PhpDebugConnection - 1186390786#----connection started
2014-06-01 10:36:02,696 [1311743]  DEBUG - p.debug.common.PhpDebugProcess - 224946154# Stop at ('file:///Users/MYUSERNAME/Sites/MAINSITE/manager.php':6)
2014-06-01 10:36:02,696 [1311743]  DEBUG - p.debug.common.PhpDebugProcess - 224946154# remote: 'file:///Users/MYUSERNAME/Sites/MAINSITE/manager.php' <-> local: '/Users/MYUSERNAME/Sites/MAINSITE/manager.php'
2014-06-01 10:36:02,696 [1311743]  DEBUG - p.debug.common.PhpDebugProcess - 224946154# remote: 'file:///Users/MYUSERNAME/Sites/MAINSITE/manager.php' <-> extracted: '/Users/MYUSERNAME/Sites/MAINSITE/manager.php'
2014-06-01 10:36:04,543 [1313590]  DEBUG - p.debug.common.PhpDebugProcess - 224946154# Stop at ('file:///Users/MYUSERNAME/Sites/MAINSITE/manager.php':7)
2014-06-01 10:36:04,543 [1313590]  DEBUG - p.debug.common.PhpDebugProcess - 224946154# remote: 'file:///Users/MYUSERNAME/Sites/MAINSITE/manager.php' <-> local: '/Users/MYUSERNAME/Sites/MAINSITE/manager.php'
2014-06-01 10:36:04,543 [1313590]  DEBUG - p.debug.common.PhpDebugProcess - 224946154# remote: 'file:///Users/MYUSERNAME/Sites/MAINSITE/manager.php' <-> extracted: '/Users/MYUSERNAME/Sites/MAINSITE/manager.php'
2014-06-01 10:36:05,264 [1314311]  DEBUG - p.debug.common.PhpDebugProcess - 224946154# Stop at ('file:///Users/MYUSERNAME/Sites/MAINSITE/manager.php':9)
2014-06-01 10:36:05,264 [1314311]  DEBUG - p.debug.common.PhpDebugProcess - 224946154# remote: 'file:///Users/MYUSERNAME/Sites/MAINSITE/manager.php' <-> local: '/Users/MYUSERNAME/Sites/MAINSITE/manager.php'
2014-06-01 10:36:05,264 [1314311]  DEBUG - p.debug.common.PhpDebugProcess - 224946154# remote: 'file:///Users/MYUSERNAME/Sites/MAINSITE/manager.php' <-> extracted: '/Users/MYUSERNAME/Sites/MAINSITE/manager.php'
2014-06-01 10:36:05,511 [1314558]  DEBUG - p.debug.common.PhpDebugProcess - 224946154# Stop at ('file:///Users/MYUSERNAME/Sites/EXTERNALLIBRARY/library.php':11)
2014-06-01 10:36:05,511 [1314558]  DEBUG - p.debug.common.PhpDebugProcess - 224946154# remote: 'file:///Users/MYUSERNAME/Sites/EXTERNALLIBRARY/library.php' <-> local: '/Users/MYUSERNAME/Sites/EXTERNALLIBRARY/library.php'
2014-06-01 10:36:05,511 [1314558]  DEBUG - p.debug.common.PhpDebugProcess - 224946154# remote: 'file:///Users/MYUSERNAME/Sites/EXTERNALLIBRARY/library.php' <-> extracted: '/Users/MYUSERNAME/Sites/EXTERNALLIBRARY/library.php'
2014-06-01 10:36:06,018 [1315065]  DEBUG - p.debug.common.PhpDebugProcess - 224946154# Stop at ('file:///Users/MYUSERNAME/Sites/EXTERNALLIBRARY/library.php':12)
2014-06-01 10:36:06,018 [1315065]  DEBUG - p.debug.common.PhpDebugProcess - 224946154# remote: 'file:///Users/MYUSERNAME/Sites/EXTERNALLIBRARY/library.php' <-> local: '/Users/MYUSERNAME/Sites/EXTERNALLIBRARY/library.php'
2014-06-01 10:36:06,018 [1315065]  DEBUG - p.debug.common.PhpDebugProcess - 224946154# remote: 'file:///Users/MYUSERNAME/Sites/EXTERNALLIBRARY/library.php' <-> extracted: '/Users/MYUSERNAME/Sites/EXTERNALLIBRARY/library.php'
2014-06-01 10:36:08,220 [1317267]  DEBUG - .connection.PhpDebugConnection - 1186390786#---schedule timeout check in 1100ms
2014-06-01 10:36:08,223 [1317270]  DEBUG - .connection.PhpDebugConnection - 1186390786#---input stream is finished
2014-06-01 10:36:08,223 [1317270]  DEBUG - .connection.PhpDebugConnection - 1186390786#---stop reading
2014-06-01 10:36:08,223 [1317270]  DEBUG - .connection.PhpDebugConnection - 1186390786#---stop writing
2014-06-01 10:36:08,223 [1317270]  DEBUG - .connection.PhpDebugConnection - 1186390786#----connection stopped

2 comments

in addition, these are the xDebug logs:

<- breakpoint_set -i 10 -t line -f file:///Users/MYUSERNAME/Sites/MAINSITE/manager.php -n 7
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="breakpoint_set" transaction_id="10" id="107950001"></response>

<- breakpoint_set -i 11 -t line -f file:///Users/MYUSERNAME/Sites/EXTERNALLIBRARY/helpers/helper.php -n 69
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="breakpoint_set" transaction_id="11" id="107950002"></response>

<- breakpoint_set -i 12 -t line -f file:///Users/MYUSERNAME/Sites/EXTERNALLIBRARY/helpers/helper.php -n 104

-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="breakpoint_set" transaction_id="12" id="107950003"></response>

0

Bless my intelligence. Wrong capitalisation in a personal configuration! :(

Apologies, sorted!!!!

0

Please sign in to leave a comment.