Opening with WAMP, browser stuck in loading, nothing displayed

Hello!

I'm new to PHPstorm and I'm still working everything out,

I've had this recurring problem since the beginning and I can't seem to figure out what exactly is causing it.

Currently it's an issue,

What Happens:


I open my script in google chrome, and instead of displaying the page, there is the loading symbol in the tab and nothing is displayed. As in, It's a blank white page in the window.

It does this sporadically too at times, i'll run a script in the browser, and it will work the first time, but I'll refresh the page, and it will get stuck.
This also happens after I run an infinite loop, and the result is I have to restart phpstorm...

I'm sorry if this is vague, but i don't know where to start, other than it's in my connection settings/xdebug

HOW I connect to the browser with wamp.


File >> Settings >> php >> php language level: 5.4
... >> + in top left >> C:\wamp\bin\php\php5.5.12 >> apply, then sychronize,

I really hope we can ask the right questions to get to the right answers

Thank you so much.

4 comments

Hi there,

http://confluence.jetbrains.com/display/PhpStorm/Installing+and+Configuring+XAMPP+with+PhpStorm+IDE

It's for configuring XAMPP .. but it should be similar.

File >> Settings >> php >> php language level: 5.4
... >> + in top left >> C:\wamp\bin\php\php5.5.12 >> apply, then sychronize,

This has nothing to do with WAMP. This is for executing local scripts & tools integration in CLI mode (and similar tools locally, e.g. CodeSniffer, PHPUnit, Composer etc)

0

Okay, looks like that is progress... I definitely didn't do the mysql / apache bits, but I had the php bin hooked up.


And now when I try to run index.php after making those changes, i'm getting a 404 page.
Suggestions from where to go from here?

0

Nope -- never worked (on serious level) with any of the WAMP/XAMPP/etc stacks myself -- only on install-it/setup-simple-website/yes-it's-workig,now-delete kind of level.  On "serious" level I work with Apache/IIS directly only.

Therefore I have to say that I have no real clue at what you have done already (since you have not mentioned anything about it) and what else you may be missing. I may only suggest to stick to one of the WAMP manuals (from scratch) and do ALL steps exactly as described there.

For this kind of question (how to configure WAMP / why it does not work) I may suggest to use stackoverflow.com as this site is more about actual PhpStorm/WebStorm

0

I just followed that guide you posted to me,

Thank you so much! (:

You don't know how much i've been struggling with that problem, it seems like it would come and go.


It worked when I created a new directory, so I just copied and pasted the files into it

I normally would've skipped out on confirming you fixed it because I was already moving on, but you saved me a big enough hassle i'll come back to give you your points (:
Thanks man. good luck with projects

0

Please sign in to leave a comment.