Webstorm 7 - cannot edit html in <body> tag.

Hi,

I have not used webstorm for a few days, and when a few days ago Istarted working and I have problem edit HTML file but only in <body> tag. I can't make a new line because key ENTER do not make a new line. I cannot put coma "," or bracket "(". What is wrong.... what I did ? I found some solution about angular.js plugin, but after remove plugin problem still persist.

Please Help !

Thanks,

Regards,
Rafal Solecki

11 comments
Comment actions Permalink

Hi there,

Latest version of WebStorm is 8.0.2. Please try it (IDE settings are stored separately).

Try disabling all 3rd party & non-bundled plugins.

In any case: please attach your idea.log (Help | Show log in...)

0
Comment actions Permalink

I've already tried ver 8.... but I used setting from version 7 (that was mistake i think) and i have same problem. I've uninstaled all 3th part plugins and this do not help. I think only reinstal Webstorm can help.



Attachment(s):
idea.log.zip
0
Comment actions Permalink

Please show a screenshot of that file -- especially that part (using Default color scheme).

Please also attach that file here as well (or some another file that has the same problem).

0
Comment actions Permalink

The issue looks related to language injections in your index.html. Please can you attach it? Do you have any custom injections configured?

0
Comment actions Permalink

I will be have access to a file later so I will upload file after 8:00pm GMT. But this "Default color scheme" I think I know what causes the problem, and I will try to solve it and I will post an answer.

Thanks for replay.

rgds,
Rafal

0
Comment actions Permalink

I got the file. It's little bit messy in this file, I hope you will find what is wrong.

0
Comment actions Permalink

I've tried this in PhpStorm v8 EAP build 138.184 (I'm not WebStorm user .. and internet is way to slow to download it here (only good for web browsing) -- maybe later at home).

I had to install Handlebars/Mustache plugin to have syntax highlighting working inside <script type="text/x-handlebars"> but it works exactly the same for me with or without that plugin -- I can edit any part of it with no side effects at all (and no exceptions in log like you had).

Therefore:
1) Could you please create brand new project and see if that file will work there
2) Have you tried disabling all 3rd aprty & non-bundled plugins? Any difference?
3) Since log is full of language injection related entries -- could you please show a screenshot of "Settings | Language Injections"

0
Comment actions Permalink

Here we go. Thanks for your effort !!



Attachment(s):
li.png
0
Comment actions Permalink

The problem is gone after when I unmark xml: body Jquery-CSS. Now I can edit, and so far do not spot any unwanted side effects.

Thanks for your EFFORT !

rgds,
Rafal Solecki

0
Comment actions Permalink

You can safely delete that entry.

Most likely you have created it by mistake somehow (e.g. when busy and not paying enough attention to the screen when typing a lot --  i.e accidentally pressed Alt+Enter and somehow chosen that option from popup menu).

You are not the first who had created such language injections rules (one again -- somehow). In other cases no editing was affected, just different colors/syntax highlighting so it is not as severe as your case here.

Since it's not first case like that (I have seen at least 4-5 in last month with similar roots on this forum) ... I guess devs have to look a bit more into it.

0
Comment actions Permalink

I was working with different keyboard languages and I was switching a lot. I remember that many times I accidently press wrong keyboard shortcut. And I remember that one shortcut I press was very fast and I hit enter after that. I believe at that time I've added this entry. But now I try and I can't reproduce it. If I will find what I did I will write what add this entry.

Thanks,

rgds,
rafal

0

Please sign in to leave a comment.