Set terminal shell path to mintty/bash?

I run PhpStorm on Windows but use Cygwin for all my terminal work.
I would like to configure PhpStorm to use Cygwin for it's terminal as well.
I tried setting the shell path to mintty.exe, but when I start the terminal mintty opens in its own window.

I also tried setting the shell path to bash.exe, which works but none of the paths are set so none cli bin files resolve.
Does anyone know how to get PhpStorm to use mintty or bash effectively?

4 comments
Comment actions Permalink

Please can you check if the problem persists in the recent PHPStorm 8 EAP? http://youtrack.jetbrains.com/issue/IDEA-124544 is closed as obsolete

0
Comment actions Permalink

Ahah, setting the terminal path to cygwin.bat works.  It works in both version 7 and EAP.  Setting it to mintty.exe causes a new window to pop up in both 7 and EAP.

Thanks for pointing out that ticket with the answer.

0
Comment actions Permalink

"C:\Program Files (x86)\Git\bin\sh.exe" --login -i

1
Comment actions Permalink

The above works, although you may need to remove the " (x86)" if you've installed the 64-bit version of Git for Windows.

0

Please sign in to leave a comment.