IDEA 4.5.4 changes line separator

I have a little problem with IDEA 4.5.4.
I have src that has unix style line separator (\n).
When i open it in IDEA and make a little change all newlines are in
windows style(\n\r).
So arch(tla) thinks that all lines are changed.
In IDEA settings/Global Code Style/General i have set Unix as line
separator.
Are there any other options i must set ?
Or is it a bug ?

mfg
Carsten

3 comments
Comment actions Permalink

Hello Carsten,

I have a little problem with IDEA 4.5.4.
I have src that has unix style line separator (\n).
When i open it in IDEA and make a little change all newlines are in
windows style(\n\r).
So arch(tla) thinks that all lines are changed.
In IDEA settings/Global Code Style/General i have set Unix as line
separator.
Are there any other options i must set ?
Or is it a bug ?


Normally, it's enough to set the line separator in the Code Style Settings.
Just check that your current project doesn't use some different custom code
style.

--
Serge Baranov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0
Comment actions Permalink

Serge Baranov schrieb:

Hello Carsten,

>> I have a little problem with IDEA 4.5.4.
>> I have src that has unix style line separator (\n).
>> When i open it in IDEA and make a little change all newlines are in
>> windows style(\n\r).
>> So arch(tla) thinks that all lines are changed.
>> In IDEA settings/Global Code Style/General i have set Unix as line
>> separator.
>> Are there any other options i must set ?
>> Or is it a bug ?


Normally, it's enough to set the line separator in the Code Style
Settings. Just check that your current project doesn't use some
different custom code style.



I checked it.
There use global Code Style is marked.
And when i click on the button it shows unix code style.
This seems to be a bug.

mfg
Carsten

0
Comment actions Permalink

Hello Carsten,

I checked it.
There use global Code Style is marked.
And when i click on the button it shows unix code style.
This seems to be a bug.


We'll investigate it. At the moment as a quick fix you can install this plug-in:
ftp://intellij.net/pub/.idea/linesepfix.jar

It makes IDEA use Unix style line separator everywhere, despite of Code Style
settings.

--
Serge Baranov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0

Please sign in to leave a comment.