Java Version Mismatch

Hi there,

I just installed Red Hat 4 Enterprise WorkStation and downloaded IntelliJ 4.5.4. When I try to run idea I get a Java Version Mismatch error saying that my install JDK is 1.4.2_07 and the version IDEA wants is 1.4.2_04. Is there any way around this? Thanks.

6 comments
Comment actions Permalink

Hello Ricardo,

Hi there,

I just installed Red Hat 4 Enterprise WorkStation and downloaded
IntelliJ 4.5.4. When I try to run idea I get a Java Version Mismatch
error saying that my install JDK is 1.4.2_07 and the version IDEA
wants is 1.4.2_04. Is there any way around this? Thanks.


To disable JDK version check specify -Didea.no.jdk.check=true in the
list of JVM arguments in idea.sh/idea.lax/idea.bat depending on your
OS version and IDEA distribution type.

--
Serge Baranov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0
Comment actions Permalink

Thanks. I edited the idea.sh file and added those JVM args. I was still getting the same error when I executed the idea executable but when I ran this command IntelliJ started just fine:

"sh idea.sh"

Any idea why?

0
Comment actions Permalink

You're supposed to run IDEA with its own bundled JRE, not your system JRE.

Hi there,

I just installed Red Hat 4 Enterprise WorkStation and downloaded
IntelliJ 4.5.4. When I try to run idea I get a Java Version Mismatch
error saying that my install JDK is 1.4.2_07 and the version IDEA
wants is 1.4.2_04. Is there any way around this? Thanks.




0
Comment actions Permalink

Um, well, IntelliJ throws an exception if I don't have the JAVA_HOME environment variable set so I presume this is not the case. Correct me if I'm wrong.

0
Comment actions Permalink

Um, well, IntelliJ throws an exception if I don't have the JAVA_HOME
environment variable set so I presume this is not the case. Correct
me if I'm wrong.


IDEA comes bundled with a JRE. I don't know how you installed IDEA, but somehow
you muts have not gotten the JRE bundled installer.


0
Comment actions Permalink

Hello Ricardo,

Thanks. I edited the idea.sh file and added those JVM args. I was
still getting the same error when I executed the idea executable but
when I ran this command IntelliJ started just fine:

"sh idea.sh"

Any idea why?


Binary executable takes JVM options from IDEA_HOME/bin/idea.lax file, lax.nl.java.option.additional
line.

--
Serge Baranov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0

Please sign in to leave a comment.