Error: 502 Bad Gateway when running php files on the built-in web server in arch linux

I've been trying to get the built-in web server in phpstorm working on arch linux for the past 3 days and I don't know why I keep getting the 502 error.  I have xampp and xdebug installed and set up in the interpreters window in settings (as shown in attached pic).  The php page I'm trying to run is a simple <?php phpinfo(); ?> page.  The error comes up in both phpstorm 7.1.3 and 8 eap 136.1382.  Hopefully someone can help me out with this.



Attachment(s):
Screenshot from 2014-04-01 12:48:12.png
1 comment
Comment actions Permalink

Hi there,

I believe it could be your php.ini settings .. or some environment (other libraries).

So far there were only 2 threads on this subject with no clear answer:

0

Please sign in to leave a comment.