4.5.3 editor doesn't accept input

OK, I know this is weird and that the problem will be stupid and utterly
my fault.

BUT, I am currently in a state that my 4.5.3 deployment (fully licensed,
of course) does not accept key input.

I tried creating a new project, added a new class, and I can't write
anything in the class code. I also tried adding a text file and that
doesn't accept input as well.

My Irida (3144) is working fine.

4.5.3 and Irida are installed in different directories and don't share
configuration or local history.

4.5.3 was working for me before, and I have no idea what happened.

I have tried Gel and NetBeans today, but I can't see the relation here.

Please help.

Thanks,
Amnon

17 comments

Weird, but I had the same problem yesterday with my notebook installation...
If you know how to reproduce it, we'll certainly fix it.
Eugene.

"Amnon I. Govrin" <amnon@netvision.net.il> wrote in message
news:crb9u1$ehp$1@is.intellij.net...

OK, I know this is weird and that the problem will be stupid and utterly
my fault.

>

BUT, I am currently in a state that my 4.5.3 deployment (fully licensed,
of course) does not accept key input.

>

I tried creating a new project, added a new class, and I can't write
anything in the class code. I also tried adding a text file and that
doesn't accept input as well.

>

My Irida (3144) is working fine.

>

4.5.3 and Irida are installed in different directories and don't share
configuration or local history.

>

4.5.3 was working for me before, and I have no idea what happened.

>

I have tried Gel and NetBeans today, but I can't see the relation here.

>

Please help.

>

Thanks,
Amnon



0

My machine has that problem now. Tell me what you want to check or do
and we can set it up, either by proxy between us or through a WebEx or
something like it.

I am basically dead in the water, as Irida has some irritating problems
and in 4.5.3 I can't write...

Amnon

Evgueny Vigdorchik wrote:

Weird, but I had the same problem yesterday with my notebook installation...
If you know how to reproduce it, we'll certainly fix it.
Eugene.

"Amnon I. Govrin" <amnon@netvision.net.il> wrote in message
news:crb9u1$ehp$1@is.intellij.net...

>>OK, I know this is weird and that the problem will be stupid and utterly
>>my fault.
>>
>>BUT, I am currently in a state that my 4.5.3 deployment (fully licensed,
>>of course) does not accept key input.
>>
>>I tried creating a new project, added a new class, and I can't write
>>anything in the class code. I also tried adding a text file and that
>>doesn't accept input as well.
>>
>>My Irida (3144) is working fine.
>>
>>4.5.3 and Irida are installed in different directories and don't share
>>configuration or local history.
>>
>>4.5.3 was working for me before, and I have no idea what happened.
>>
>>I have tried Gel and NetBeans today, but I can't see the relation here.
>>
>>Please help.
>>
>>Thanks,
>>Amnon


0

OK, I massaged the plug-ins and I can write again... I updated
PropertiesEditor but I bet it is not related to a specific but rather to
saving a configuration file), and I would stretch my guess to be some
kind of Irida / 4.5.3 interaction issue. Though I don't share
configuration files, I do share project files to some extent (note,
however, that the problem persisted when I created a new project on 4.5.3)

Amnon

0

I had exactly this problem and it related to PropertiesEditor switching from Irida back to 4.5.3 and an exception that gets thrown at startup time. Removing PropertiesEditor fixed it.

Jon

0

Oh, and the strange thing was that the keyboard worked for navigation in the editor, just not for typing anything.

It seems to be a bug in both PE and IDEA: IDEA in that it is so vulnerable at startup and PE that it can throw such a startup exception.

0

PE author interested in catching of this exception...

TIA,
Dmitry

0

To reproduce, started with 4.5.3 with PE then switched to Irida and all was okay. Switched back to 4.5.3 and then IDEA startups get an exception from PE such that you can't get characters out of keyboard in the editor. Removed PE from 4.5.3 and all is fine. Reinstall PE and all is still fine. I think this is the exception that starts the problem during IDEA's startup:

Jon

2004-12-09 12:24:18,874 ERROR - llij.ide.plugins.PluginManager -
2004-12-09 12:24:18,874 ERROR - llij.ide.plugins.PluginManager - IntelliJ IDEA 4.5.3 Build #2250
2004-12-09 12:24:18,874 ERROR - llij.ide.plugins.PluginManager - JDK: 1.4.2_04
2004-12-09 12:24:18,874 ERROR - llij.ide.plugins.PluginManager - VM: Java HotSpot(TM) Client VM
2004-12-09 12:24:18,874 ERROR - llij.ide.plugins.PluginManager - Vendor: Sun Microsystems Inc.
2004-12-09 12:24:18,874 ERROR - llij.ide.plugins.PluginManager - OS: Windows XP
2004-12-09 12:24:18,874 ERROR - llij.ide.plugins.PluginManager - Last Action:
2004-12-09 12:24:18,874 ERROR - llij.ide.plugins.PluginManager -
java.lang.NoClassDefFoundError: com/intellij/openapi/fileTypes/StdFileTypes

at com.propertiesEditor.propedit.PropertiesFileEditorComponent.isAcceptedExtension(PropertiesFileEditorComponent.java:150)

at com.propertiesEditor.propedit.model.bundle.BundleManager.getBundleForFile(BundleManager.java:44)

at com.propertiesEditor.propedit.model.bundle.BundleManager$3.run(BundleManager.java:119)

at com.intellij.openapi.progress.a.a.runProcess(a.java:65)

at com.intellij.openapi.o.b.c$1a_.run(c$1a_.java:8)

0

PE for Irida and Pallada is different versions. Problems possible and very probable. It's combination of compatibility and clas loading problem.

TIA,
Dmitry

0

Okay. Can PE itself notify that it is the wrong match between Irida/Pallada? This was the most nasty problem in IDEA I've run across in recent times. Not your area, but for the IntelliJ folks, can IDEA startup be made more robust that keyboard input to editor doesn't get lost in such a situation?

Thanks,
Jon

0

Best solution is uninstall bad plugin in error message dialog cause handle such situations not possible in general case I'm affraid.

TIA,
Dmitry

0

I don't believe this problem triggered the uninstall bad plugin dialog.

Jon

0

No I mean initial exception during IDEA startup.

0

Dmitry Kashin wrote:

Any details on it?


Where can I get previous versions so that I can see if they break my
4.5.3 again?

Thanks,
Amnon

0

Jon Steelman wrote:

I don't believe this problem triggered the uninstall bad plugin dialog.

Jon

It didn't on my machine.
Amnon

0

Main problems:
PE wraps too much.
IDEA load plugins which descriptor not fit to current version, it use since tags only when loading plugins not starting application.

TIA,
Dmitry

0

Please sign in to leave a comment.