Problem with Typescript Definitions

Webstorm isn't recognizing my 3rd party libraries - jQuery, Angular, Underscore, etc. I've downloaded the latest files from DefinitelyTyped and included them in to my project. I've tried reinstalling Typescript. I've tried invalidating the cache and restarting. My calls to the type definitions seem to be correct. Nothing is working and I'm completelly stumped.

I'm using the latest version of Webstorm 7 and Typescript.

/// <reference path='../type_definitions/jquery.d.ts' />
/// <reference path='../type_definitions/jqueryui.d.ts' />
/// <reference path='../type_definitions/angular.d.ts' />
/// <reference path='../type_definitions/underscore.d.ts' />
/// <reference path='../type_definitions/google.maps.d.ts' />

Here's my file watcher settings:

file-watcher-settings.jpg

Thanks in advance.

1 comment
Comment actions Permalink

Hello!

are the paths in <reference path> resolved by compiler? What errors are shown when running the file watcher? And what's the reason for using -noResolve option? The resolution and preprocessing are skipped, so types from external files won't be found

0

Please sign in to leave a comment.