webapp woes - anyone else see tomcat spew this:

Hi,

I having been quite a time getting my webapp to work.

I am using 4.5.2 and tomcat 5.0.29.

I had the simplest case working OK - a basic Hello page, but when I tried to get an example struts app working things went down hill.

I start the webapp, get an green deployment but then console fills up with stuff along these lines (see below)

Once this happens I have to force a restart.

I have tried 4.5.2 and tomcat 5.0.25 with same results.

I have tried 4.5.1 with same results as well.

If anyone has some pointers for me I'd appreciate it.
Also, if there is complete web module documentation somewhere I'd love to know about that too.

Thanks in advance.

tomcat spews

Oct 18, 2004 10:15:25 AM org.apache.catalina.core.StandardHostDeployer install
INFO: Processing Context configuration file URL file:C:\sam\idea-settings\4.5.2\system\tomcat_pain_28e204e9\conf\Catalina\localhost\ROOT.xml
0 DEBUG org.apache.catalina.startup.TldConfig - Accumulating TLD resource paths
0 DEBUG org.apache.catalina.startup.TldConfig - Scanning ]]> elements in web.xml
0 DEBUG org.apache.catalina.startup.TldConfig - Scanning TLDs in /WEB-INF subdirectory
0 DEBUG org.apache.catalina.startup.TldConfig - Scanning TLDs in /WEB-INF/ewarezWeb.iml subdirectory
0 DEBUG org.apache.catalina.startup.TldConfig - Scanning TLDs in /WEB-INF/struts-config.xml subdirectory
16 DEBUG org.apache.catalina.startup.TldConfig - Scanning TLDs in /WEB-INF/tld subdirectory
16 DEBUG org.apache.catalina.startup.TldConfig - Adding path '/WEB-INF/tld/c-rt.tld'
16 DEBUG org.apache.catalina.startup.TldConfig - Adding path '/WEB-INF/tld/c.tld'
16 DEBUG org.apache.catalina.startup.TldConfig - Adding path '/WEB-INF/tld/fmt-rt.tld'
16 DEBUG org.apache.catalina.startup.TldConfig - Adding path '/WEB-INF/tld/fmt.tld'
16 DEBUG org.apache.catalina.startup.TldConfig - Adding path '/WEB-INF/tld/sql-rt.tld'
16 DEBUG org.apache.catalina.startup.TldConfig - Adding path '/WEB-INF/tld/sql.tld'
16 DEBUG org.apache.catalina.startup.TldConfig - Adding path '/WEB-INF/tld/struts-bean-el.tld'
16 DEBUG org.apache.catalina.startup.TldConfig - Adding path '/WEB-INF/tld/struts-bean.tld'
16 DEBUG org.apache.catalina.startup.TldConfig - Adding path '/WEB-INF/tld/struts-html-el.tld'
16 DEBUG org.apache.catalina.startup.TldConfig - Adding path '/WEB-INF/tld/struts-html.tld'
16 DEBUG org.apache.catalina.startup.TldConfig - Adding path '/WEB-INF/tld/struts-logic-el.tld'
16 DEBUG org.apache.catalina.startup.TldConfig - Adding path '/WEB-INF/tld/struts-logic.tld'
16 DEBUG org.apache.catalina.startup.TldConfig - Adding path '/WEB-INF/tld/struts-nested.tld'
16 DEBUG org.apache.catalina.startup.TldConfig - Adding path '/WEB-INF/tld/struts-tiles-el.tld'
16 DEBUG org.apache.catalina.startup.TldConfig - Adding path '/WEB-INF/tld/struts-tiles.tld'
16 DEBUG org.apache.catalina.startup.TldConfig - Adding path '/WEB-INF/tld/x-rt.tld'
16 DEBUG org.apache.catalina.startup.TldConfig - Adding path '/WEB-INF/tld/x.tld'
16 DEBUG org.apache.catalina.startup.TldConfig - Scanning TLDs in /WEB-INF/web.xml subdirectory
32 DEBUG org.apache.catalina.startup.TldConfig - Scanning TLD at resource path '/WEB-INF/tld/x.tld'
328 DEBUG org.apache.commons.digester.Digester - addRuleSet() with no namespace URI
328 DEBUG org.apache.commons.digester.Digester.sax - setDocumentLocator(org.apache.xerces.parsers.AbstractSAXParser$LocatorProxy@cafb56)
328 DEBUG org.apache.commons.digester.Digester.sax - startDocument()
438 DEBUG org.apache.commons.digester.Digester.sax - notationDecl(WEB-JSPTAGLIB.1_2,-//Sun Microsystems, Inc.//DTD JSP Tag Library 1.2//EN,null)
453 DEBUG org.apache.commons.digester.Digester.sax - startElement(,,taglib)
453 DEBUG org.apache.commons.digester.Digester - Pushing body text ''
453 DEBUG org.apache.commons.digester.Digester - New match='taglib'
453 DEBUG org.apache.commons.digester.Digester - No rules found matching 'taglib'.
453 DEBUG org.apache.commons.digester.Digester.sax - ignorableWhitespace(
)
453 DEBUG org.apache.commons.digester.Digester.sax - startElement(,,tlib-version)
453 DEBUG org.apache.commons.digester.Digester - Pushing body text ''
453 DEBUG org.apache.commons.digester.Digester - New match='taglib/tlib-version'
453 DEBUG org.apache.commons.digester.Digester - No rules found matching 'taglib/tlib-version'.
453 DEBUG org.apache.commons.digester.Digester.sax - characters(1.0)
453 DEBUG org.apache.commons.digester.Digester.sax - endElement(,,tlib-version)
453 DEBUG org.apache.commons.digester.Digester - match='taglib/tlib-version'
453 DEBUG org.apache.commons.digester.Digester - bodyText='1.0'
453 DEBUG org.apache.commons.digester.Digester - No rules found matching 'taglib/tlib-version'.
453 DEBUG org.apache.commons.digester.Digester - Popping body text ''
453 DEBUG org.apache.commons.digester.Digester.sax - ignorableWhitespace(
)

1 comment

Are you by chance using log4j? try to rename the log4j.properties or log4j.xml file as log4j.backup. if you're not using log4j, then perhaps it is another config file that it is choking on.. i'm not sure of the issue but ran into similar symptoms when debugging log4j.. hope that helps.

0

Please sign in to leave a comment.