CVS gzip problems

We recently switched CVS providers and with the new CVS provider we can't seem to get ssh to work properly using gzip compression. Using gzip is critical because for a typical update IntelliJ sends upto 135k to the server, without gzip compression turned on it transmits at about 1k per second, with gzip its totally fast.

I'm running v 4.5.3. Under the old CVS provider it worked.

Old provider CVS version:1.11
New provider CVS version:1.12

Anyway, the error I get is "unknown compression method". Looking at the log it seems like the issue is with IntelliJ (since the Exception is on the read). Here's the stack trace:

2004-12-07 15:10:52,549 INFO - ort2.javacvsImpl.io.ReadThread - Stopping CvsReadThread Thread[CvsReadThread,10,Idea Thread Group], atEnd: true, firstIndex: 82, lastIndex: 82, exception: null, closed: true
2004-12-07 15:10:52,643 INFO - ellij.openapi.vcs.VcsException -
java.util.zip.ZipException: unknown compression method
at java.util.zip.InflaterInputStream.read(InflaterInputStream.java:140)
at java.util.zip.InflaterInputStream.read(InflaterInputStream.java:105)
at com.intellij.cvsSupport2.javacvsImpl.io.StreamLogger$3.read(StreamLogger.java:4)
at org.a.a.a.b.c.a(c.java)
at org.a.a.a.b.b.read(b.java:5)
at org.a.a.a.t.a(t.java:44)
at org.a.a.a.t.a(t.java:64)
at org.a.a.a.t.a(t.java:27)
at org.a.a.a.t.a(t.java:49)
at org.a.a.a.g.c.d.a(d.java:12)
at com.intellij.cvsSupport2.cvsoperations.common.CvsCommandOperation.a(CvsCommandOperation.java:30)
at com.intellij.cvsSupport2.config.CvsRootConfiguration$1.run(CvsRootConfiguration.java:9)
at com.intellij.openapi.progress.a.a.runProcess(a.java:65)
at com.intellij.openapi.o.b.c$1a_.run(c$1a_.java:8)

Is there any way to get the exact command that IntelliJ sends to the server, even with the Show CVS output setting I'm getting nothing in the consol but the error.

1 comment

The gzip issue turned out to be a red herring. We had some permission issues on CVSROOT/config and CVSROOT/loginfo. After setting the right permissions we're able to use ssh.

0

Please sign in to leave a comment.