Can Tomcat and Weblogic share Web.xml?

I'm trying to setup two containers (Weblogic 8.1 SP3 and Tomcat 5.0.28) to develop one application. I have already set up both containers outside of IntelliJ without problems, however I would like to run them within IntelliJ. I can set them both up individually within IntelliJ (ie I can setup Tomcat when Weblogic is not setup, and vice versa) without problems, however when I try to setup the Weblogic instance once Tomcat has already been set up then it does not seem to detect any web modules under the "Deployment" tab within the "Weblogic Instance" tab of the Configuration Setup bit.

I receive a warning saying "There are no modules in the project configured to Weblogic Server". Pressing the "Fix" button solves the matter by finding the web.xml from my application development directory, however it appears to have "stolen" it from the Tomcat configuration as I now receive the same warning under the "Tomcat Server" tab.

So, I guess the problem is that the "Weblogic Instance" and "Tomcat Server" configurations cannot both point to the same web.xml file for some reason? Has anyone else had any similar experiences?

Thanks

3 comments
Comment actions Permalink

Hi,

web.xml is reused for the different application servers, but
in one moment of time the module is bound to one application server, so
when you are going to run server different from the web module is
attached to then IDEA complains.

Gareth Western wrote:

I'm trying to setup two containers (Weblogic 8.1 SP3 and Tomcat 5.0.28) to develop one application. I have already set up both containers outside of IntelliJ without problems, however I would like to run them within IntelliJ. I can set them both up individually within IntelliJ (ie I can setup Tomcat when Weblogic is not setup, and vice versa) without problems, however when I try to setup the Weblogic instance once Tomcat has already been set up then it does not seem to detect any web modules under the "Deployment" tab within the "Weblogic Instance" tab of the Configuration Setup bit.

I receive a warning saying "There are no modules in the project configured to Weblogic Server". Pressing the "Fix" button solves the matter by finding the web.xml from my application development directory, however it appears to have "stolen" it from the Tomcat configuration as I now receive the same warning under the "Tomcat Server" tab.

So, I guess the problem is that the "Weblogic Instance" and "Tomcat Server" configurations cannot both point to the same web.xml file for some reason? Has anyone else had any similar experiences?

Thanks



--
Best regards,
Maxim Mossienko
IntelliJ Labs / JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

0
Comment actions Permalink

Thanks for your reply!

So is there any way to attach the web module to multiple application servers?

0
Comment actions Permalink

No, but you can switch them as you need this.

Gareth Western wrote:

Thanks for your reply!

So is there any way to attach the web module to multiple application servers?



--
Best regards,
Maxim Mossienko
IntelliJ Labs / JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

0

Please sign in to leave a comment.