Color syntaxing problem with inline style and JS

Hi, I'm pretty new with phpstorm, I've just been playing around with it for an hour or so, and I begun by changing the color scheme to match the colors I'm used to

I have a problem : Phpstorm is coloring inline styles and javascript, instead of treating them like strings, as I'm used to

I'd prefer to have phpstorm just displaying the parts shown in the big red squares in my printscreen with only one color (let's say pink :) )

Here i'd like for exemple "setTimeout('CheckedCID()',200)" to be just pink (including the quotes if i can)
And the same goes for example for the 'width:600px' in the second line


Comment actions Permalink

Hi there,

You will need to check (and change) styles for JavaScript and CSS for that.

IDE automatically injects corresponding languages into those places, so the coloring styles for those languages will be used (as well as code completion and syntax checking for that specific language).

You may check if disabling Language Injection rules will help here (if it does then in this case content will be treated as plain text) -- "Settings | Language Injections".

Comment actions Permalink

Thanks for your reply

I've already disabled all defaults Language injection rules, I've forgot to mention that, sorry

So it's not helping :/

Comment actions Permalink

No one?
It's trivial, but I just can't work with this program, code isn't easily readable that way

I already deactivated (unchecked all and applied, I suppose it's enough) all rules in Setting/Language Injections, why does phpStorm keep treating inline onclick=, onmouseover=, style= etc.... as code to parse and color?

Is there something I missed, or is it a "it works like that and you can't change it" kind of thing?

Comment actions Permalink


JS/CSS injections in HTML are hard-coded and can't be turned off. If you  need this feature, please feel free to file a request to youtrack (

Comment actions Permalink

well that's a no-go for me then

i'll post a request, just in case, but I'll pass on your soft for now, too bad

thanks for your reply



Please sign in to leave a comment.