PhpStorm automatic watches gone

Hello,

I've made PHP and PhpStorm update a couple of weeks ago and since then automatic watches in Debug panel are gone. Now I have to add global variables, like $_POST and local scope variables manually, which is annoying.
I'm on Ubuntu 12.04 with PHP 5.5.9, xdebug 2.2.3, PhpStorm 7.1.2.

Here is xdebug.conf:

zend_extension=/usr/lib/php5/20121212/xdebug.so

[XDebug]
xdebug.remote_enable=true
xdebug.remote_port=9000
xdebug.profiler_enable=0
xdebug.profiler_output_dir=
xdebug.show_local_vars=1
xdebug.show_exception_trace=1
xdebug.remode_host="localhost"
xdebug.remote_handler="dbgp"



PhpStrom settings are ok to my mind. Correct version of PHP is chosen, also xdebug is set as debugger.
Maybe I'm missing something crucial that was introduced in recent versions?

6 comments
Comment actions Permalink

Can you try File | Invalidate caches and restart? If issue remains, attach your idea.log: Help | Show log in explorer.

Also can you add new watches?

0
Comment actions Permalink

Hello,

thank you for the answer!
Invalidating hash didn't help. Please find todays log in attachment.

Best regards,
Alexander.



Attachment(s):
idea.log.zip
0
Comment actions Permalink

I've also tried creating project from scratch with existing sources and it also didn't solve the problem.

0
Comment actions Permalink

Hi there,

Could you please:

1) Upgrade to the latest PhpStorm v7.1.3.

2) See if restarting web server / computer will do any difference (sometimes it works even for Linux, not just Windows :) )

3) See if disabling all 3rd party plugins will change anything

4) Provide output of phpinfo() (the xdebug part at very least)

5) As I understand debugging still works (i.e. it stops on breakpoints, manual watches work etc)

6) Please provide more detailed logs:
  a) from xdebug side: http://xdebug.org/docs/all_settings#remote_log (restarting web server may be required)
  b) same but from PhpStorm side:

  • clear idea.log so it has only recent relevant info
  • while IDE is closed, enable extra logging: http://devnet.jetbrains.com/docs/DOC-1202
  • launch IDE and attempt to debug some rather simple PHP script (preferably in brand new empty project)
  • attach idea.log again
  • provide screenshot of the debug panel during debugging

Maybe I'm missing something crucial that was introduced in recent versions?

AFAIK -- no. Works OK here (Windows 7 x64, IIS 7.5, PHP 5.5.9 x86 (via FastCGI for web requests), xdebug 2.2.3, PhpStrorm 7.1.3)

0
Comment actions Permalink

Are you sure you not just accidentaly minimised it?
Try looking for that glasses icon in top RIGHT corner of debugger window, or hovering cursor over the right inner edge - does it look like "splitter beam"?
IDE screenshot will be much appreciated.

0
Comment actions Permalink

Right, it came out it was hidden between "Frames" and "Watches" panels The "Variables" pannel didn't appear even when I moved "Watches" to the right and only showed up when I clicked "Hide" button on the top-right of the "Watches" panel.
Thank you and everybody who helped to solve the issue very much!

0

Please sign in to leave a comment.