http://site.local instead of http://localhost/site.local/www . how to?

My webapp sources (folder site.local) are under my local server document root (xampp/htdocs).
Apache httpd-vhosts.conf is configured so that the web root of my webapp 'DocumentRoot "/xampp/htdocs/site.local/www"' is mapped to 'ServerName site.local', since in browser address bar I want to see http://site.local instead of http://localhost/site.local/www.
Netbeans allows me to set up my webapp in such a manner and I can run my webapp right out from this IDE and get what I want, but my wish is to launch my webapp via Alt+F2 right out from PhpStorm editor window and to have in browser address bar http://site.local.
How can I do that?



Attachment(s):
2319.jpg
1842.jpg
4 comments
Comment actions Permalink

Hi there,

Settings | Deployment


Configure entry of correct type (since you have your project file already there, the "In Place" is the one to use) and mark it as Default for this project (don't forget).

0
Comment actions Permalink

thanks for reply, BUT
this doesn't help (or I can't sort it out yet)
see attachments: they are self-explaining AFAIK

P.S. sorry for pressing 'Post' before attached the last screenshot, but here its contents:
Object not found!
The requested URL was not found on this server. If you entered the URL manually please check your spelling and try again.
If you think this is a server error, please contact the webmaster.
Error 404
localhost
Apache/2.4.4 (Win32) OpenSSL/0.9.8y PHP/5.4.19



Attachment(s):
03_with_www.jpg
04_no_www.jpg
03_no_www.jpg
02.jpg
01.jpg
0
Comment actions Permalink

You need to pay more attention to what you are doing.

On screenshot #2 -- why do you have "http://localhost" in "Web server root URL" field if you plan to use "http://site.local" ???

On screenshot #3 -- why do you put "site.local" -- the text below it (in blue) shows the final Project URL -- it's definitely not what you want to use.. but you still using it... why ??


Now .. accordingly to screenshot #1 your project root is "D:\xampp\htdocs\site.local" while website root (DocumentRoot in Apache config) is set to "D:\xampp\htdocs\site.local\www".  Currently IDE does not have separate setting where you can say "this is my website root folder" (like Netbeans has). Two options here:

  1. either make project root to be "D:\xampp\htdocs\site.local\www"
  2. ... or add additional mapping as described in this comment: http://youtrack.jetbrains.com/issue/WI-15169#comment=27-656716 .  If not sure on this one -- what needs to go where -- feel free to ask (assuming that first 2 were corrected)
0
Comment actions Permalink

thank you for this input

you saved my day

it works as I wanted

(screenshots attached)

have a good weekend



Attachment(s):
07.jpg
06.jpg
05.jpg
0

Please sign in to leave a comment.