Multiple issues with Generated Ant files

Let me first say that I LOVE this functionality. But here are the
issues I'm having.

1) When I first created the files I opted to have multiple files. The
properties that were created in the base file were not recognized in the
module file (were higlighted in red saying "cannot resolve symbol"). It
worked anyway when I built it so this is just an idea problem not a
problem for ant.

2) The tool created the following lines:
but the problem was that there was no library.tomcat.classpath path created prior. I solved this by adding: but I have to add this anytime I generate files. 3) ]]>

Again idea says "cannot resolve symbol" for j2ee.path.jar and highlights
it in red. Again this does not create a problem for builds but it does
show the ant file as having errors.

It would be great if idea was able to show the values of those types of
properties also. Maybe when you mouse-over it.

-Thanks

2 comments
Comment actions Permalink

You really should file all this in Tracker so they can fix em.

R

0
Comment actions Permalink

Good luck. Been there, done that - marked do not fix.

http://intellij.net/tracker/idea/viewSCR?publicId=31787

To the the generated ant file should WORK. Not generate a file that I
have to sift through and fix.

Norris Shelton
Sun Certified Java Programmer




Robert S. Sfeir wrote:

>You really should file all this in Tracker so they can fix em.
>
>R

>

0

Please sign in to leave a comment.