Web Module with IDEA 4.5

There was a similar subject, but for 4.03. My issue is pretty much the same, but I didn't know if it was handled differently in 4.5

Basically, I've created a Run/Debug configuration for a Tomcat Server. I select Local, and set the "Application Server" to an existing Tomcat 5 (5.0.27). When it starts, it displays CATALINA_BASE as c:\Document and Settings\name\.IntelliJIdea\....

Someone in the similar thread mentioned that these settings were in the catalina.bat file. However, the only time I see it setting CATALINA_BASE is when it sets it to CATALINA_HOME if it didn't exist already.

5 comments
Comment actions Permalink

Well... To answer my own question.. I ended up having to edit the catalina.bat file in my bin directory, setting CATALINA_BASE. I tried several things, setting an environment variable, even setting up the configuration to pass the environment variables... Only the above step seemed to work...

Anyone have a better solution?

0
Comment actions Permalink

When you configure the App Server there is a field for Tomcat Home and Tomcat Base Directory. So in your Run/Debug Configuration on the Tomcat Server tab, look on the Server tab and you should see that Application Server drop down and next to it the Configure button. Click on that to set the home and base.

0
Comment actions Permalink

I have always wondered why IntelliJ does not come with a servlet.xml for
tomcat. Our servlet.xml is munged pretty badly to support our
production environment. This makes it useless for IJ to use to launch
an application.


Vincent Fischer wrote:

>There was a similar subject, but for 4.03. My issue is pretty much the same, but I didn't know if it was handled differently in 4.5
>
>Basically, I've created a Run/Debug configuration for a Tomcat Server. I select Local, and set the "Application Server" to an existing Tomcat 5 (5.0.27). When it starts, it displays CATALINA_BASE as c:\Document and Settings\name\.IntelliJIdea\....
>
>Someone in the similar thread mentioned that these settings were in the catalina.bat file. However, the only time I see it setting CATALINA_BASE is when it sets it to CATALINA_HOME if it didn't exist already.

>

0
Comment actions Permalink

Hi,

One more note on this advice:
- Base directory specified in Application Server dialog is "User" base
directory, the IDEA copies the config settings to its own hidden place
and modify them to enable debugging.

Zoltan Grose wrote:

When you configure the App Server there is a field for Tomcat Home and Tomcat Base Directory. So in your Run/Debug Configuration on the Tomcat Server tab, look on the Server tab and you should see that Application Server drop down and next to it the Configure button. Click on that to set the home and base.



--
Best regards,
Maxim Mossienko
IntelliJ Labs / JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

0
Comment actions Permalink

You don't want to debug in the same kind of environment as your production server? I think it is great that IDEA takes the developers config files rather than some clean-room version so that I don't have to test and debug twice.

0

Please sign in to leave a comment.