How to disable "multiline" when using "Find" tool

I frequently am trying to use ctrl-f to "find" some string within my code and somehow activate the "multiline" find capability. Maybe it's because I paste something with multiple lines into the "find" field.. But I'm unsure, because if I test it now, multiline pastes simply go into one line.

Anyway, somehow I activate the multiline button, which sucks because if I hit "enter", PhpStorm does not "find" - it just puts a new line into my search query. I have to either manually click the find button or manually click the "multiline" button.

Is there a hotkey which enables/disables this? I feel as though when you hover over the multiline button there should be some sort of indicator of what I'm doing to enable this.

Thanks?

2 comments
Comment actions Permalink

Hello!

there are no shortcuts for switching to multiline mode - you can only do this by pressing the button. Pressing the same button once more turns multiline mode off

0
Comment actions Permalink

Thanks! So ... what triggers it? Maybe 2% of the time when I am trying to Find something, I paste (or do something else) and multiline mode is triggered. Turning it off again is not the issue; it's that I have to break workflow to reach for my mouse and press the little button. I'd love to do most things by the keyboard. :)

0

Please sign in to leave a comment.