svn and .idea

Currently trialing PhpStorm 7.1 and really liking it thusfar. However, the svn integration is frustrating me.

I don't want any of the project metadata in my repo. Reason being is that there are several people working on the project and they can use whatever IDE they want. I want a clean repository without any IDE specific clutter. So I add the .idea folder to the ignore list in the phpstorm version control settings then import to the repo and the .idea folder still gets committed. I tried this with the 'include ignored resources' checkbox checked and unchecked and still I find .idea in my repo!

So I search the net a bit a find that it is recommended to check in the .idea directory but ignore workspace.xml. Ok then maybe I'll stop fighting PhpStorm and try the recommended way instead even though it clutters the repo. I then find that workspace.xml still gets committed to my repo even though it is on the ignore list by default in preferences?!

Is this a bug? How can I avoid checking in .idea (or even workspace.xml for that matter)?

I'm running on OSX 10.8.5

3 comments
Comment actions Permalink

Please see: http://youtrack.jetbrains.com/issue/WI-343 . Try workaround suggested there.

0
Comment actions Permalink

Adding to the ignore list is the right way to go. But note that svn:ignore only affects files that have not been added yet. Did you add workspace.xmlto the repository? If yes, it will be commited despite being added to ignore list

0
Comment actions Permalink

Thanks for the replies Elena and Liubov.
Tried this again with new project but still files and directories on the preferences->version control->ignored files list are getting committed when importing to svn.
Then tried the work around and changed my source code directory in preferences->directories and had success in that .idea is no longer being committed but now I get svn E155007 is not a working copy errors.

0

Please sign in to leave a comment.