How to change the look of current highlight variable?

I have just upgraded webstorm to 7.0.3.

In this version, if you click on a variable, it will be decorated with a green underscore. It annoys me. I really want the old look & feel back. But I can't find the option in Colors & Fonts to change that.

Any idea?

11 comments
Comment actions Permalink

Hello!

not sure what 'green underscore' you are talking about - can you provide a screenshot? Does this highlighting apper on simple ckick, or on ctrl+click, when a variable turns into a hyperlink to its definition? BTW, nothing seems to have changed here since previous versions

0
Comment actions Permalink

I have the same problem. Before version 7.0.3, when i was selecting a variable, all its usages in the same file were highlited by changing their background. It was easy to spot the places where they were used.
Now, in version 7.0.3, they are only underlined (green line when they are read, orange line when they are assigned). But they are harder to see.

Is any way to change it back?

0
Comment actions Permalink

please attach the screenshot, as requested above. Your settings (File/export settings) would also help

0
Comment actions Permalink

Hi,

I attached a screenshot displaying the way WebStorm 7.0.3 is highlighting the selected variable: by underlining the usages instead of changing the background color as in previous version.



Attachment(s):
highlighted variables - WebStorm 7.0.3.png
0
Comment actions Permalink

I see, thanks for screenshot:) So you are using Dsarcula theme. You can change the way variable is highlighted in Settings/Editor/Colors&fonts/General,
'Identifier under caret' and 'Identifier under caret(write)' options. Highlighting has been changed to make it more readable

3
Comment actions Permalink

Thank you. :) That fixed the problem.

0
Comment actions Permalink

How can I change the color of the other instances of the variable I selected?

The issue is shown in the screenshot below. When I highlight temp1_s32 at line 30, I can barely see temp1_s32 at line 32. I'd like to change the background color of temp1_s32 at line 32 to be more noticeable.

 



1
Comment actions Permalink

It appears to be Settings | Editor | Colors & Fonts | General > Identifier under caret.

3
Comment actions Permalink

Hi Vladimir

It looks like they've moved it in 2017.1.2. Under Editor, there is a "Caret" but no "Identifier under caret". 

When I select "Caret", it has a totally different color scheme that what I posted above, so it can't be that.

Thanks for your help

0
Comment actions Permalink

"Identifier under caret" -- such options are are under "General | Code" (read and write styles)

 

If it's still not correct style (which is unlikely) -- check under "General | Search Results" -- "Search result" when variable does read operation" and "Search result (write access)" when variable is used in write operation.

0
Comment actions Permalink

Thanks Andriy. Found it. Thanks for your help folks. 

Settings | Editor | Colors & Fonts | General | Code > Identifier under caret

0

Please sign in to leave a comment.