Deployment via FTP - No files or folders found to process

Hi all,

I recently startet evaluating PHPStorm 2.0.1 and I have to say I really like it. It's so feature rich that I'm really inclined to substitute my NetBeans IDE with PHPStorm.

Nonetheless, I ran into an error I simply can't get rid of or find a solution for:
I defined a deployment target (FTP server), did all the mappings an so on, but... it keeps telling me, that  "No files or folders found to process" whenever I hit "Upload to XXX" or "Deployment -> Upload to XXX" in the context menu or in the Tools menu.

Now I thought my setup or configuration is invalid, but by chance I activated "automatic upload" and it really does exactly what I want whenever I save changes to a file. So my configuration and mapping must be correct. Alas, the complete upload / deployment does still not work, and of course I do not want to auto-deploy each and any file at any time...

Please, could someone tell me what I'm doing wrong?


Best greetings,

ThaGoob

10 comments
Comment actions Permalink

Hello Thadaus,

The simplest way to find the problem is to enable logging, try to invoke manual upload and attach the log file. Please find exact steps here.

Regards,
Kirill

0
Comment actions Permalink

Hi Kirill,

I did as you told me. The log is attached.

I don't know completely how to read it, but I noticed that whenever automatic upload jumps in, there is a lot of information and transfer log lines. But when I try to deploy manually, all I see is:

DEBUG - t.connections.RemoteConnection - Reusing connection to ftp://192.168.211.6:21/
DEBUG - t.connections.RemoteConnection - Releasing one of the connections to ftp://192.168.211.6:21/


Your help is really appreciated,

Thadäus



Attachment(s):
idea.2011-05-12.log.zip
0
Comment actions Permalink

Thanks for the logs, this is definitely a bug: http://youtrack.jetbrains.net/issue/WI-6280. Please watch/vote for it to be nofiied on updates.

Workaround is to use different local folder, that has no %20 as part of it's name.

Regards,
Kirill

0
Comment actions Permalink

Regarding empty folders in version 6 and lower by default when you  delete all files inide folder phpstorm also removed folder i guess that  was a feature

I dont think this message is a bug considering above i am sure is some kind of feature they created, i had smae message when i tried to upload empty folder over ftp however when i create file in that folder it uploaded just fine.


I wish i know how where is option to disable both of this frustrating features!


Workaraound to original question is "Brose Remote Host" and drag and drop file from your local folder tree to remote host this way it will upload.

EDIT:

I actually just found the optopn to allow upload of empty folders, its under Tools > Deployment > Options its called "Create empty directories" if you check it, phpstorm will stop showing this message and upload empty folders

1
Comment actions Permalink

I had this error because i've excluded some directories from deployment in ftp settings. I've tried to use "Remove path from excluded" in "Remote host" tab, then to download this directory, and there i had this error. The solution that worked for me - go to  Tools > Deployment > Configuration -> choose your deployment here -> tab "Excluded Paths" and remove path for your directory, then download using Remote host tab worked.

0
Comment actions Permalink

I was having an issue loading files when I set up an FTP setup. The deployment setup would make a good connection but not list any of the files. I activated the log files but there was no error being output.  To fix this it was a bit of trail and error.  Finally in the deployment setting I clicked on "Advanced options" and clicked the "Passive Mode" checkbox.  This worked for me. Unfortunately I don't know enough about ftp and lack time to research why this worked but maybe someone who knows more about it can chime in why this solution worked.  Hope it works for others if you have the issue. 

2
Comment actions Permalink

Thanks Garret! Your comment saved me a ton of time. This should definitely be in the documentation.

0
Comment actions Permalink

Hello!

I have same problem.

After commit cant deploy files cause an error [30.07.2019 15:09] No files or folders found to process

- Settings is good

- With mapping

- Without excluded paths

- My version

By the way, on first save settings and first commit/deploy, all was OK, but on subsequent commit/deploy - getting error :(

Logs here:

2019-07-30 15:09:08,594 [9316268] INFO - #git4idea.commands.GitHandler - [gdebar] git -c core.quotepath=false -c log.showSignature=false add --ignore-errors -A -f -- public_html/App/Admin/templates/button-bron.phtml
2019-07-30 15:09:08,714 [9316388] INFO - #git4idea.commands.GitHandler - [gdebar] git -c core.quotepath=false -c log.showSignature=false commit -F C:\Users\Максим\AppData\Local\Temp\git-commit-msg-.txt --amend --
2019-07-30 15:09:08,993 [9316667] INFO - #git4idea.commands.GitHandler - [master 3410db77] поправил работу с партнёрами в админке
2019-07-30 15:09:08,994 [9316668] INFO - #git4idea.commands.GitHandler - Date: Tue Jul 30 13:32:43 2019 +0300
2019-07-30 15:09:08,994 [9316668] INFO - #git4idea.commands.GitHandler - 2 files changed, 36 insertions(+), 23 deletions(-)
2019-07-30 15:09:08,994 [9316668] INFO - #git4idea.commands.GitHandler - rewrite public_html/App/Admin/templates/button-bron.phtml (100%)
2019-07-30 15:09:09,018 [9316692] DEBUG - t.connections.RemoteConnection - Opening connection to ftp://62.109.8.247:21/ in @4d50398d
2019-07-30 15:09:09,018 [9316692] DEBUG - t.connections.RemoteConnection - Added connection to pool offtp://62.109.8.247:21/ in @4d50398d; 1 connections exists
2019-07-30 15:09:09,019 [9316693] DEBUG - t.connections.RemoteConnection - Releasing one of the connections to ftp://62.109.8.247:21/ in @4d50398d; connections left 0

1
Comment actions Permalink

Hello!
After updating to version 2019.2 (192.5728.108) I also cant upload after a commit/deploy. I have to deploy manually for it to work.

1
Comment actions Permalink

It's https://youtrack.jetbrains.com/issue/WI-47590, and it's gonna be fixed in the next minor release.

0

Please sign in to leave a comment.