Deployment via FTP - No files or folders found to process

Hi all,

I recently startet evaluating PHPStorm 2.0.1 and I have to say I really like it. It's so feature rich that I'm really inclined to substitute my NetBeans IDE with PHPStorm.

Nonetheless, I ran into an error I simply can't get rid of or find a solution for:
I defined a deployment target (FTP server), did all the mappings an so on, but... it keeps telling me, that  "No files or folders found to process" whenever I hit "Upload to XXX" or "Deployment -> Upload to XXX" in the context menu or in the Tools menu.

Now I thought my setup or configuration is invalid, but by chance I activated "automatic upload" and it really does exactly what I want whenever I save changes to a file. So my configuration and mapping must be correct. Alas, the complete upload / deployment does still not work, and of course I do not want to auto-deploy each and any file at any time...

Please, could someone tell me what I'm doing wrong?

Best greetings,



Hello Thadaus,

The simplest way to find the problem is to enable logging, try to invoke manual upload and attach the log file. Please find exact steps here.



Hi Kirill,

I did as you told me. The log is attached.

I don't know completely how to read it, but I noticed that whenever automatic upload jumps in, there is a lot of information and transfer log lines. But when I try to deploy manually, all I see is:

DEBUG - t.connections.RemoteConnection - Reusing connection to
DEBUG - t.connections.RemoteConnection - Releasing one of the connections to

Your help is really appreciated,



Thanks for the logs, this is definitely a bug: Please watch/vote for it to be nofiied on updates.

Workaround is to use different local folder, that has no %20 as part of it's name.



Regarding empty folders in version 6 and lower by default when you  delete all files inide folder phpstorm also removed folder i guess that  was a feature

I dont think this message is a bug considering above i am sure is some kind of feature they created, i had smae message when i tried to upload empty folder over ftp however when i create file in that folder it uploaded just fine.

I wish i know how where is option to disable both of this frustrating features!

Workaraound to original question is "Brose Remote Host" and drag and drop file from your local folder tree to remote host this way it will upload.


I actually just found the optopn to allow upload of empty folders, its under Tools > Deployment > Options its called "Create empty directories" if you check it, phpstorm will stop showing this message and upload empty folders


I had this error because i've excluded some directories from deployment in ftp settings. I've tried to use "Remove path from excluded" in "Remote host" tab, then to download this directory, and there i had this error. The solution that worked for me - go to  Tools > Deployment > Configuration -> choose your deployment here -> tab "Excluded Paths" and remove path for your directory, then download using Remote host tab worked.


I was having an issue loading files when I set up an FTP setup. The deployment setup would make a good connection but not list any of the files. I activated the log files but there was no error being output.  To fix this it was a bit of trail and error.  Finally in the deployment setting I clicked on "Advanced options" and clicked the "Passive Mode" checkbox.  This worked for me. Unfortunately I don't know enough about ftp and lack time to research why this worked but maybe someone who knows more about it can chime in why this solution worked.  Hope it works for others if you have the issue. 


Thanks Garret! Your comment saved me a ton of time. This should definitely be in the documentation.


Please sign in to leave a comment.