[File Watchers] 'C:\Users\Username' is not recognized as internal or external command

Hi there,
O have been using for more than a year now, and never had this error before. if I try to compile TypeScript or SCSS files to js or css, I get the following error :
"'C:\Users\Abderrahmane' is not recognized as an internal or external command,
operable program or batch file."

in the following screen all the relevent information present. and the output that I get after compilation.

at first I got it in SCSS, but it did not bother me since I could still get the files compiled, but in TypeScript it does not.

Thanks
phpstorm.png

12 comments

Hello!

please specify a full path to tsc.cmd in the program field

0

I have tried both representations of the Path to my typescript binaries, and it still give me the same error.

0

I'm not sure what you mean by PATH representations to typescript binaries... Please speciofy a full path to your cmd file in the program field of your file watcher. According to screenshots, you have it set to 'tsc.cmd'. It should be smth like C:\Users\your.name\AppData\Roaming\npm\tsc.cmd

0

by two representations I meant :

  • C:\Users\Abderrahmane\AppData\Roaming\npm\tsc.cmd
  • tsc.cmd
I have tried both these representations to tsc.cmd, and yet I still get this error
0

that's really strange.
Please provide screenshots showing up the watcher configuration and run console messages whern a full path is being used

0

please can you attach your idea.log?


0

please also execute 'echo %PATH%' in the cmd window and send me the output

From http://i.imgur.com/2U1xoqR.png I can see that the same error is reported when you open windows cmd prompt

0

Thank you very much. it helped instantly :D have a good day. a good year. happy new year, happy holidays

0

Please sign in to leave a comment.