How I fixed broken XDebug/PHPStrom configuration

I was sitting on a coach working with my laptop with PHPStorm and XDebug installed and working. It was all good and I was happy until I shut down my laptop and slept. The day after that: it wasn't working anymore! Here is my installation:

  • Debian 7 Wheezy
  • PHPStorm 7.0
  • PHP 5.4.4-14
  • Xdebug v2.2.1

I followed guide here (http://blog.jetbrains.com/webide/2011/02/zero-configuration-debugging-with-xdebug-and-phpstorm-2-0/) for zero configuration of PHPStorm and XDebug and it was working. This is my xdebug configuration file in my Debian 7:

/etc/php5/mods-available/xdebug.ini

zend_extension=/usr/lib/php5/20100525/xdebug.so

xdebug.remote_enable=1

xdebug.remote_handler=dbgp

xdebug.remote_host=localhost

xdebug.remote_port=9000


If the path is different from what you have seen before, this is how it is in Debian 7. The debugging was stopped working and PHPStorm couldn't get the break points after I reloading the chrome browser. This was the solution:

With the project opened, I went to File> Settings> PHP> Servers> Unchecked Use path mappings
Hope it help others but the question is:

Why the hell it was turned on! If it is the default settings, why it was working before and why I now need to uncheck it to keep using XDebug?

Please sign in to leave a comment.