PHPStorm 7.0, PHPUnit on server - cannot get work

Hello,

I cannot get work phpunit on server feature. I've tried plenty of different variants and options, but finally I fail with error 500 :(

My "server" is local virtual OS (debian 7) on vagrant. On guest system: PHP 5.4, PHPUnit 3.7.28, xdebug is also installed (version 2.2.3). All tests work in the console (via ssh). But in phpstorm I get 500 error without any explanations.

I tried configure server both "in place" and "Local or mounted folder". Server validation passes in both cases (take a look on screenshots):
Screen Shot 2013-11-22 at 13.18.07.png
Screen Shot 2013-11-22 at 13.19.04.png
Each time I get immedieately:

Testing started at 13:20 ...
Executing tests
Http request failed: HTTP/1.0 500 Internal Server Error

And that's all.

My run configuraions seems like:
Screen Shot 2013-11-22 at 13.21.49.png
I tried different combinations of test runner options, different targets (directory, file, class, method, XML). Tried specify alternative config.xml with different options. But finally I still have the same issue :(

File _intellij_phpunit_launcher.php is created and executed when I run tests. It actually has access to phpunit, because when I try trigger it manually without parameters, I get message from phpUnit that says I should specify correct CLI arguments (nothing to do, just as run phpunit without arguaments).

Looking forward for your help... Thanks in advance.

1 comment

Found source of the problem... I used environment variables in test fixtures and some of "require", that relied on these variables, failed. Everything went ok when running from console, but when triggering URL - these variables were not set.
So I set them from phpunit.xml and now everything works.

0

Please sign in to leave a comment.