Wrong debugger is used on start of PHPUnit

I'm trying now PHPStorm 6.0.3 and have a problem to setup right debugger for PHPUnit

My preferred debugger would be Zenddebugger (works perfectly when testing code).

But when I'm trying to debug PHP unit, it is started with following options

"C:\Program Files (x86)\Zend\ZendServer\bin\php.exe" -dxdebug.remote_enable=1 -dxdebug.remote_host=127.0.0.1 -dxdebug.remote_port=9000 -dxdebug.remote_mode=req C:\Users\xxx\AppData\Local\Temp\ide-phpunit.php --configuration D:\Tests\php\phpunit.xml

and respectively uses xDebug instead of ZendDebugger


I've checked all possible settings in PHPStorm Settings dialog, all INI-fies (PHP, Zend, Windows), registry, but did not found mentioned options for using xdebug in PHP Unit

So my questions are:
- can I make PHPStorm 6 use Zend debugger also for PHPUnits (if yes - how) ?
- or is xDebug the only debugger that can be used for PHPUnit under 6 version of PHPStorm?

2 comments

Hi there,

I do not have Zend Debugger myself .. so cannot verify this for you (all my PHPUnit experience is linked to xdebug).

But here are couple of questions:
1) What debugger do you see in "Settings | PHP | Interpreters" (the "..." button) -- for CLI scripts (which PHPUnit is) it should be taken from there.
2) Please show output of phpinfo();  (or "php -i" for CLI) -- top summary part where it tells what debugger(s) you have

P.S.
PhpStorm v7 is out for a while now.

0

Thank you for reply

I've alrerady found the answer in one of your :-) previous posts
It was wrong Debugger setting for Interpreter, i've missed that

0

Please sign in to leave a comment.