Getting modules to show up in run server deployment tab

Alright, my modules have once again dissapeared off the deployment tab. Previously the solution was to edit the j2ee-integration to have my DK name in it.

Now that no longer seems to work, and no matter what I do, j2ee-integration is always set to 'Generic Application Server' with no modules showing up in the deployment tab.

2 comments
Comment actions Permalink

Same probs here on OS X. I faked a change in the list of relative paths, and once you click apply the module shows back up. That said, I still can't start an app server on here, nor can I get the tag libs to be recognized, and further the button and a good chunk of the bottom of the ide settings display shoots way off the bottom of the screen on my Mac.

I filed bugs where I noticed that the runtime configs are just plain wrong. First there is one for every single type of app server (Tomcat, JSR45, and Weblogic), the context path is not saved so it's always blank, and the ports for all app server is 7001.

There is nothing I can muster out of 2051 to get it to do much of anything. At this point I'm waiting for yet another build with the hopes something works.

Maxim, you really ought to try things on OS X or Linux, if it works on windows doesn't mean it works elsewhere :)

R

0
Comment actions Permalink

Oh and one more bug... it seems idea doesn't care what your exploded dir is, if it's not the content root of your project, it still doesn't put the WEB-INF/web.xml where it should be. It always ends up in the content root of your project. But even copying it over to the exploded dir makes no difference.

R

0

Please sign in to leave a comment.