Sass file watcher errors out

so I create a .scss file in a directory in my project
I get a message asking me to set up a file watcher
I click "add watcher"
then I get an output window with the following output :

/usr/bin/scss --no-cache --update blah.scss:blah.css

/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems.rb:777:in `report_activate_error': Could not find RubyGem sass (>= 0) (Gem::LoadError)

 from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems.rb:211:in `activate'

 from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems.rb:1056:in `gem'

 from /usr/bin/scss:18

when I run
/usr/bin/scss --no-cache --update blah.scss:blah.css
on the commandline from the dir where blah.scss lives it correctly generates blah.css

Anyone have any ideas why the watcher doesn't believe it can find the gem?

Be at ease,
Kristopher.

2 comments

Hi Kristopher,

please try running PHPStorm (or WebStorm - not sure what IDE you are using) from terminal, like "open -a /Applications/PhpStorm.app/" - does it help? See http://stackoverflow.com/questions/18193043/error-using-phpstorms-sass-file-watcher for more info
0

following instructions in that stack link I changed the path var in my scss watcher config and now it works,
Thanks!

0

Please sign in to leave a comment.