Stop PHPStrom from messing up my parentheses

Hi,

ever since I upgraded to PHP 7 I'm having troubles with the autocomplete for parenthesis. It used to behave in a different way, where I could "overwrite" parentheses when typing. Now whenever I open an html class for instance, it automatically fills in parentheses, however not letting me overwrite them. Since I'm used to writing them out, I always get two opening parentheses, since they won't be replaced, which makes it look like this: asdasd"". Is there a way to regain the option to replace autofilled parentheses, when writing them out? It would even help if I could simply deactivate the autocomplete-parentheses funtion. Disabeling "Insert pair quote" under Editor->Smart Keys in the settings panel sadly didn't do the trick :/

3 comments

Ahh, thanks a lot! And I thought I'm just too retarded to find it. Guess I have to wait till 7.1 then.

0

You can try EAP build right now (if this issue is critical for you) -- it is stable enough (I'm using on daily basis). Just install in separate folder (they will share the same config folder) and switch back to 7.0 if necessary.

http://blog.jetbrains.com/phpstorm/2013/11/phpstorm-7-1-eap-133-51/

0

Please sign in to leave a comment.