Can't use Xdebug anymore

Since yesterday phpstorm stopped working with xDebug.

Environment:
- Mac OS X 10.9
- MAMP PRO 2.1.4
- PHP 5.4.10

This, from terminal, shows nothing:

netstat -an | grep 9000

I'm using MAMP PRO, with PGP 5.4:

$ ls -alr /usr/bin/php

lrwxr-xr-x  1 root  wheel  44 15 Nov 15:40 /usr/bin/php -> /Applications/MAMP/bin/php/php5.4.10/bin/php

$ which php

/Applications/MAMP/bin/php/php5.4.10/bin/php

This is the content of .profile (not idea of what created that: I might have done it, but I don't remember when or why):

test -r /sw/bin/init.sh && . /sw/bin/init.sh

export PATH=/Applications/MAMP/bin/php/php5.4.10/bin:/sw/bin:/sw/sbin:/usr/bin:$


There are no .bash_profile or .bash_rc files.

You can find phpinfo and phpStorm PHP setting attached.
Always in the attachments, you can see the remote environment validation (though, before having the issue, I didn't have to configure this, or to validate it).

If I add a breackpoint, enable the debug listener and click on the browser bookmarklet, nothing happen when I open/refresh the page.

If I add to the test script this:
echo 'xdebug_is_enabled() = ' . xdebug_is_enabled();

I get:
xdebug_is_enabled() = 1



If I add this:
xdebug_break();

Nothing happens.


Please, help me: I need to fix some issues in a php script and without the debugger it's a nightmare!


Thanks.


Attachment(s):
Schermata 2013-11-19 alle 10.13.45.png
Schermata 2013-11-19 alle 10.12.27.png
phpinfo.pdf
1 comment
Comment actions Permalink

Well, as usual, after struggling for hours and posting in the forum, I've found the solution.

For some reason phpStorm option to listen external connections was disabled.

Solved.

0

Please sign in to leave a comment.