PhpStorm not detecting changes

Hey everyone

My Phpstorm 7.0 running under CentOS is not detecting filesystem changes anymore. Im working on a local disc and already increased /proc/sys/fs/inotify/max_user_watches to 524288.
If I switch git branches or modify files outside of phpstorm, it doesnt take notice of it. I've already invalidated caches and so on. After a restart of phpstorm all changes are detected properly.

Do you have any tipps how to solve this?

Thanks, best regards

3 comments
Comment actions Permalink

Hi there,

If I switch git branches or modify files outside of phpstorm, it doesnt take notice of it.

"Settings | General | Synchronize files on frame activation" -- do you have that enabled? Any hints in the idea.log (Help | Show Log in...)

Do you have any tipps how to solve this?

Does "File | Synchronize" do the job? (Obviously, it's rather manual workaround than permanent automatic solution -- I'm not a Linux guy at all to suggest anything better).

0
Comment actions Permalink

Hi

Thanks for the reply.

I have Synchronize files on frame activation enabled. The log doesnt contain any helpful entry.

File|Synchronise starts the spinning arrow-wheel icon in the bottom-left corner but does not have any further effect...

0
Comment actions Permalink

I've completly reinstalled Phpstorm and configured again from scratch and now it seems to be working again.. not a nice solution, but at least working..

0

Please sign in to leave a comment.