Vaildate Remote Environment - Does Not Work

No matter what settings I try, I get "Failed to execute validation script"
10 comments

Hello,

Please, describe your environment settings. What kind of deployment settings are you using in you project?  Does it work for your project files? Do you have web server running on the remote environment?

0

We have several different deployment configurations. I can't even get it to work on localhost for an in-place server.

local1.JPG

0

I guess you have shared folder between remote and local environment (like Vagrant) or even you are trying to validate local environment. Am I right? Please, check that project files can be accesible by web path from your deployment configuration.
If there is no problem with path mappings, please, send your 'php_info()' output.



Attachment(s):
in_place_deployment.png
0
I'm just trying to test a local only server. Yes, that configuration works fine for my actual web server, I just can't get the Validate to work. I can't send my entire php_info(), as that has senstive data in it. What portion do you need?
0

I need information about your PHP version (yes, php_info() isn't necessary for it) and information about your web server.
Also, please check our latest EAP, there were some changes in validation proccess.

0

I am still struggling with this - I really need is the ability to debug a server remotely. The server runs PHP CLI scripts. I can remotely debug IIS scripts on the same server, but not the CLI scripts:

I can't pos our phpinfo() here, it has passwords in the environment variables (legacy, to be removed.)

System Windows NT APP02 6.1 build 7601 (Windows Server 2008 R2 Web Server Edition Service Pack 1) i586
Build Date Sep 18 2013 12:58:28
Compiler MSVC11 (Visual C++ 2012)
Architecture x86
Configure Command cscript /nologo configure.js "--enable-snapshot-build" "--enable-debug-pack" "--disable-zts" "--disable-isapi" "--disable-nsapi" "--without-mssql" "--without-pdo-mssql" "--without-pi3web" "--with-pdo-oci=C:\php-sdk\oracle\instantclient10\sdk,shared" "--with-oci8=C:\php-sdk\oracle\instantclient10\sdk,shared" "--with-oci8-11g=C:\php-sdk\oracle\instantclient11\sdk,shared" "--with-enchant=shared" "--enable-object-out-dir=../obj/" "--enable-com-dotnet=shared" "--with-mcrypt=static" "--disable-static-analyze" "--with-pgo"
Server API CGI/FastCGI
Virtual Directory Support disabled
Configuration File (php.ini) Path C:\Windows
Loaded Configuration File C:\php\php.ini
Scan this dir for additional .ini files (none)
Additional .ini files parsed (none)
PHP API 20121113
PHP Extension 20121212
Zend Extension 220121212
Zend Extension Build API220121212,NTS,VC11
PHP Extension Build API20121212,NTS,VC11
Debug Build no
Thread Safety disabled
Zend Signal Handling disabled
Zend Memory Manager enabled
Zend Multibyte Support provided by mbstring
IPv6 Support enabled
DTrace Support disabled
Registered PHP Streams php, file, glob, data, http, ftp, zip, compress.zlib, https, ftps, phar, sqlsrv
Registered Stream Socket Transports tcp, udp, ssl, sslv3, sslv2, tls
Registered Stream Filters convert.iconv.*, mcrypt.*, mdecrypt.*, string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, dechunk, zlib.*
0

And to be clear, PHPStorm "catches" the debugger output, the path mappings are not specified.

0

Please, provide your idea.log (Help->Show Log in...)? It will help us to see if the validation script is creating in the right directory.
Also attach a screenshot with your in-place deployment configurations.

If you are using in-place configuration, what do you mean under "the path mappings are not specified"? If it's really "in-place" you don't need any mappings.
Please, clarify your environment configuration. Are the folders with your project and opened in PhpStorm exactly the same?

0

I think I figured it out. We use Windows Authentication on all of our IIS servers:

2013-10-29 09:52:21,000 [14166374]   WARN - ation.PhpRemoteDebugValidation - GET method failed for "http://app02.pridedallas.com/_intellij_phpdebug_validator.php" with HTTP status 401.

0

Great!
Please, feel free to submit feature request for server authentification: http://youtrack.jetbrains.com/issues/WI

0

Please sign in to leave a comment.