How do I update the SSH console font?

How do I update the SSH console font? The one that's being used isn't very readable:

phpstorm-font-issue.png

I've also attached the image, in case this inline image isn't very readable either... As you can see, the IDE and file lists are just fine. However, the console is all mucked up. It's like it's trying to use a font in an inappropriate size.



Attachment(s):
phpstorm-font-issue.png
5 comments

Should be in Settings | Editor | Colors & Fonts | Console Font.  You'll need to open a new terminal/console to see it; the old one will retain the previous settings.

0

It works, kinda. I found  a couple problems, for me: 1) it won't save between restarts. 2) it won't let me actively edit the list. I have to passively force the edit by dbl-click until the font I want is there, move it to the bottom, hit "apply" and then the highlight will move to the top of the list. From there, I can remove each one by double-click.... Very tricky, and definitely a "work-around" to a bug.

0

Please show a screenshot of that settings screen -- you must be doing something wrong (as I understand you are using Darcula UI theme).

0

Here you go. The options are grayed out. But I can vaguely interact with them. And yes, it's the Darcula theme.

phpstorm-settings.png

0

Thanks.

They are greyed out because they are disabled.

They are disabled because it is not possible (not meant) to edit any of the bundled schemes.

You need to create a copy of desired/most-appropriate-for-you scheme and then you can freely customize it as you wish (use "Save as..." button for that)

0

Please sign in to leave a comment.