TortoiseSVN & phpStorm

Good day.
After I updated Tortoisesvn to version

TortoiseSVN 1.8.2, Build 24708 - 32 Bit , 2013/08/27 19:20:39
Subversion 1.8.3, -release
apr 1.4.8
apr-util 1.5.2
serf 1.3.1
OpenSSL 1.0.1e 11 Feb 2013
zlib 1.2.8

Stopped working in phpstorm 6.0.3 and the new version phpstorm 7.
In what could be the problem and what information you might not be enough?

2 comments
Comment actions Permalink

I believe the problem is that it's using Subversion 1.8, which is not yet ready for use in PhpStorm due to SVNKit being out of date.  From my understanding, the JetBrains folks are trying to rewrite the SVN handling code from scratch so this problem doesn't happen again in the future, but for now you'll have to stick with 1.7 working copies.  I think I recall reading that it might be nearing completion at some point in the (not too distant) future and that it might be able to be released in a 7.0.x patch.

0

Please sign in to leave a comment.