phpstorm 6 doesn't seem support remote xdebug sessions

Hi,

I followed the guide to configure phpstorm with xdebug (http://confluence.jetbrains.com/display/PhpStorm/Zero-configuration+Web+Application+Debugging+with+Xdebug+and+PhpStorm#), but phpstorm doesn't want to connect to the remote debugger. It's not listening to connections on port 9000, and in general doesn't really seem to do anything. Doesn anyone have a link to a correct guide to configure phpstorm, or perhaps another IDE that does support xdebug?

4 comments

Hi there,

but phpstorm doesn't want to connect to the remote debugger.

Please check basic facts -- it's xdebug who connects to IDE and NOT other way around.

http://xdebug.org/docs/remote

Doesn anyone have a link to a correct guide to configure phpstorm

It's a correct guide -- it works just fine. Most likely you are doing something wrong (or forgot to do something, like restarting apache after making changes in php.ini or whatever)


Enable logging on xdebug side -- http://xdebug.org/docs/all_settings#remote_log -- it will tell you what it tries to do. If log is empty -- then you have not configured xdebug correctly .. or xdebug does not see debug request at all.
0

After restarting phpstorm, it now seems to be listening (according to netstat). There's a second problem though, there are no incoming connections. This is my xdebug.ini file:


zend_extension=/usr/lib/php5/20100525/xdebug.so
xdebug.default_enable=1
xdebug.profiler_enable_trigger=1
xdebug.profiler_output_dir=/tmp
xdebug.var_display_max_children=512
xdebug.var_display_max_data=-1
xdebug.var_display_max_depth=-1
xdebug.remote_enable=1
xdebug.remote_port="9000"
xdebug.remote_port="192.168.10.157"
xdebug.profiler_enable=1
xdebug.profiler_output_dir="/tmp"

192.168.10.157 is the IP of my development PC, port 9000 is the port it's listening on. I've tried turning debugging on with the bookmarklets linked in the guide, and by sending the GET variable ?XDEBUG_SESSION_START=PHPSTORM and the cookie XDEBUG_SESSION = PHPSTORM and reloading the page. But there seems to be no connection from the server to the PC.

0

Thanks for the remote_log suggestion. It turns out that I put
xdebug.remote_port="9000"
xdebug.remote_port="192.168.10.157"

instead of
xdebug.remote_port="9000"
xdebug.remote_host="192.168.10.157"

Thanks again.

0

Please sign in to leave a comment.