"Clear read-only status" not possible on Win 7 HP 64

Hi everybody,

I installed PHPStorm 6.0.3 on a Win 7 Home Premium 64 Bit standalone notebook and selected "New project from existing files". That worked fine, but PHPStorm tells me, that it would not be possible to save the project file. The "Clear read-only status"-window appears. Only the option "Using file system" is selectable, but nothing happens when I press [OK]. I tried to run phpstorm.exe as administrator, but that didn't help.

Can anyone of you help?

Thanks in advance,

--
Bfn
Michael

2 comments

Hi there,

1) What Windows Explorer says about that file (file attributes; any encryption; any symlinks) ?

2) Do you (your user account) have FULL access to that file (Running as Admin is not the same as full access)

3) If any antivirus/continuous backup is running -- will it work if you temporarily disable it?

4) Please try the same in v7 EAP build -- PhpStorm EAP

0
 
Andriy,

> 1) What Windows Explorer says about that file (file attributes; any encryption; any symlinks) ?

Existing Project-Folder is e.g. documents\myproject. When I select "Create project from existing files", a subdirectory named .idea is created and here I find a file named .name. When I choose to create a new project and copy my files into the new project folder, the .idea-folder contains e.g. .name, encodings.xml, misc.xml, modules.xml, phps2.iml, scopes, vcs.xml, workspace.xml





> 2) Do you (your user account) have FULL access to that file (Running as Admin is not the same as full access)

Yes. I work with Windows Administrator priviliges, and I can create/write/read/delete files in documents\myproject\.idea with no limits.


> 3) If any antivirus/continuous backup is running -- will it work if you temporarily disable it?

I use BitDefender, which unfortunately doesn't have a Disable function. I would have to deinstall it. But if BitDefender would deny PhpSTorm from creting files, it would tell me so and log it.



> 4) Please try the same in v7 EAP build -- PhpStorm EAP

 
Unfortunately the same problems.  


--
Bfn
Michael

0

Please sign in to leave a comment.