Vagrant open dialog

Hello to all.

When I go to "Tools > Vagrant > Init in Project Root" (or Up) phpstorm presents me with a dialog to open a file. There's no description, no message, nothing. Just the dialog. I know it requires a file, because it doesn't allow me to select a directory (I thought, perhaps it wanted a machine root or something). When using "up" and selecting the "vagrantfile" of my existing vagrant setup, the dialog closes and nothing happens.

Does anyone have any idea about what I'm doing wrong? I've attached screenshots of the steps, as well as my settings and the version I'm using.

I'm using the EAP 131.98 on Mac OSX 10.8.5
The Vagrant version is 1.3.3



Attachment(s):
version.png
step3.png
step2.png
step1.png
settings.png
9 comments

I have been following that to the letter even before posting my question. I've nicely used google like I should :D That's exactly how I got into trouble.

0

Well ... since I do not use this technology myself, I can only suggest checking your idea.log for possible details/hints ("Help | Show Log in Finder" .. or very similar to this (not a Mac user either))

0

Shows nothing. It doesn't update when going through the steps again. Should I add a ticket to the issue tracker?

0

I would suggest waiting a day or so before submitting a ticket -- one of the devs/supports are likely to notice this thread (since they supposed to check forum on regular basis).

But if no feedback will be received -- feel free to file new ticket (but check for possible duplicates here as well before submitting).

BTW --  what's your vagrant version?

0

Thanks. The version I'm using is 1.3.3 (I'll update the thread description accordingly).

0

Rather random idea -- if you have time and desire -- would you like to to try 1.2.x branch instead of 1.3.x ?

0

I've stumbled upon this: https://github.com/mitchellh/vagrant/issues/2231 so I tried 1.3.2, no luck. Then I got your reply, and tried 1.2.7, and voila...

A `Vagrantfile` has been placed in this directory. You are now
ready to `vagrant up` your first virtual environment! Please read
the comments in the Vagrantfile as well as documentation on
`vagrantup.com` for more information on using Vagrant.

Process finished with exit code 0


It does sound like a bit of a problem. Should I create an issue, or should I just assume that "they know".
0

Well ... I, personally, would wait for the next EAP build before making a ticket. Possibly it was fixed already (this one is about running it on Windows though .. and behaviour is a bit different, but there is a chance that your case would be covered as well).

But it's up to you, actually -- no one will be hurt or anything like that with extra ticket.

0

Please sign in to leave a comment.