Intellisense and pinning/docking of views have stopped working

All I can say is that intellisense and the pinning to sidebar of views have mysteriously stopped working a week ago or so and this is the first chance I've had to pursue why. Are these a known issues?Thanks, Mike
5 comments
Forgot to mention I'm using Phpstorm 6.0.3.
0
I've solved the pinning of views to sidebar. The Views > Tool Buttons was disabled.Still not seeing why intellisense isn't working.
0

Hi there,

All I can say is that intellisense and the pinning to sidebar of views have mysteriously stopped working

What do you mean by "stopped working"? Does IDE offer any code completion? or marks standard PHP functions/classes are "unknown" (or something like that)?  Details/screenshots please.

In any case: Have you tried "File | Invalidate Caches..."? -- usually helps when such "suddenly stopped working/green code is shown red" happens.
0
Thanks for the response. When I say 'stopping working' that is meant literally. Nothing. Might as well be using Notepad...just teasing. :)  A while back I did make some modification to syntax highlighting but did not notice whether or not it stopped working then. I'm currently looking through Settings but not finding much. Can it be explicitly turned off/on? I did reluctuntly clear the cache.I know this isn't a lot to go on. I'm faced with the same dilemma. Hard to debug without any hints.Mike
0
Found the problem. At the same time I was changing the syntax highlighting, I also enabled Power Saving Mode. I just disabled it (see attached image) and intellisense is back. My bad!!Sorry to bother you. Thanks, Mike

Attachment(s):
phpstorm.png
0

Please sign in to leave a comment.