WebStorm auto tagging

Hello,

I've recently started using WebStorm for my smaller test projects, and I am very fond of it so far. However I've recently encountered frustrating behavior which I do not know how to overcome. I've looked in the discussions and the knowledge base but haven't found anything useful yet.

I am trying to get the word 'Menu' into the content of an HTML tag, but WebStorm keeps making it a tag for me, and closing it.

<h1><Menu></Menu></h1>

I've looked in the preferences in Smart Keys and Code Completion, but nothing that catches my eye seems to work.

Can someone tell me how to prevent this behavior?

thanks,
Carl Martin

5 comments

I've just discovered that it is wrapping any text I add in tags when I hit the spacebar.
Obviously there's something very nooby going on, but I still need help with it.

Thanks,
Carl Martin

0

Hi there,

  1. "Settings | Editor | Code Completion --> Autopopup code completion" -- see if unchecking this option will help.
  2. Do you have any 3rd party (not-bundled) plugins installed? See if disabling them will make any difference.
  3. Settings | Keymap -- search for actions (button next to bin icon) by shortcut (Space ?? in your case) -- see what actions are assigned to it.
  4. Settings | Keymap -- see if changing it to default one will help.


As last resort -- you can always delete your IDE settings while WebStorm is closed -- on next launch it will recreate all defaults ( IDEA files locations )

0

Thanks for your help. Nothing worked except deleting all the config files.

In Windows 7, I deleted the contents of /<User>/.WebStorm6/config.

In OSX 10.8.4, I deleted everything in ~/Library/Preferences/WebStorm6. The link posted for the IDEA file locations wasn't up to date or relevant to WebStorm.

It still would be nice to know what setting changed that, but I'll be more careful this time.

Thanks!

0
It still would be nice to know what setting changed that, but I'll be more careful this time.

If you have backups of your original config (maybe you did it before deleting it) then you can compare new to old file by file...

Other than that -- maybe it's Live Templates or Emmet support ... but it should not affect every single word (as you have said).

0

Check comments in: http://youtrack.jetbrains.com/issue/IDEA-110640

It's Emmet support -- this is how it behaves when you set Expand key to be "Space" instead of "Tab".

0

Please sign in to leave a comment.